PAT A1076:Forwards on Weibo之BFS求解

题目描述

1076 Forwards on Weibo (30分)
Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers:
N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows;
and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.
Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

求解思路

  • 题意:在微博中,每个用户都可能被若干个其他用户关注。而当该用户发布一条信息时,他的关注者就可以看到这条信息并选择是否转发它,且转发的信息也可以被转发者的关注者再次转发,但统一用户最多只转发该信息一次(信息的最初发布者不会转发该信息)。现在给出N个用户的关注情况(即他们各自关注了哪些用户)以及一个转发层数上限L,并给出最初发布消息的用户编号,求在转发层数上限内消息最多会被多少用户转发。
  • 首先考虑如何建图。由于题目给定的数据是用户关注的情况(而不是被关注的情况),因此如果用户X关注了用户Y,则需要建立由Y指向X的有向边,来表示Y发布的消息可以传递到X并被X转发。
  • 在建图完毕后,使用BFS来遍历,把结点编号和层号建立成结构体,然后控制遍历层数不超过L。

代码实现(AC)

#include<cstdio>
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
const int maxn=1001;
struct Node{
	int id;
	int layer;
	//Node(int _id,int _layer):id(_id),layer(_layer){}	//构造函数 
};
vector<Node> edge[maxn];
bool vis[maxn]={0};
int n,l,k;
void init()
{
	scanf("%d %d",&n,&l);
	for(int i=1;i<=n;i++)
	{
		Node user;
		user.id=i;
		int m;
		scanf("%d",&m);
		for(int j=1;j<=m;j++)
		{
			int userFollow;
			scanf("%d",&userFollow);
			edge[userFollow].push_back(user);
		}
	}
}
int BFS(int s,int L)
{
	int numForward=0;
	queue<Node> q;
	Node start;
	start.id=s;
	start.layer=0;
	q.push(start);
	vis[start.id]=1;
	while(!q.empty())
	{
		Node topN=q.front();
		q.pop();
		int u=topN.id;
		for(int i=0;i<edge[u].size();i++)	
		{
			Node next=edge[u][i];
			next.layer=topN.layer+1;
			//如果next结点未被访问过且层数不超过L则让其入队
			if(!vis[next.id]&&next.layer<=l)
			{
				q.push(next);
				vis[next.id]=1;
				numForward++;
			} 
		}
	} 
	return numForward;	
}
void solve()
{
	init();
	int k;
	scanf("%d",&k);
	for(int i=1;i<=k;i++)
	{
		int s;
		scanf("%d",&s);
		fill(vis,vis+maxn,0);
		printf("%d\n",BFS(s,l));
	}
}
int main()
{
	solve();
	return 0;	
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值