PAT A1037:Magic Coupon

题目描述

1037 Magic Coupon (25分)
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 -1 }, and a set of product values { 7 6 -2 -3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC , followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC ,NP ≤10^5 , and it is guaranteed that all the numbers will not exceed 2^30 .

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

求解思路

给定序列c和序列p,其中序列c的长度为nc,序列p的长度为np。需要我们求得两个序列相乘得到的最大值。故我们只需要将两个序列从小到大排序,首先遍历两个序列中值小于0的元素,然后遍历两个序列中值大于0的元素。

代码实现(AC)

#include<cstdio>
#include<algorithm>
using namespace std;
int nc,np;
void solve()
{
	scanf("%d",&nc);
	int c[nc];
	for(int i=0;i<nc;i++)
		scanf("%d",&c[i]);
	scanf("%d",&np);
	int p[np];
	for(int i=0;i<np;i++)
		scanf("%d",&p[i]);
	sort(c,c+nc);
	sort(p,p+np);
	int ans=0,i=0,j=0;
	while(c[i]<0&&p[j]<0&&i<nc&&j<np)
	{
		ans+=c[i]*p[j];
		i++;
		j++;
	}
	i=nc-1;
	j=np-1;
	while(c[i]>0&&p[j]>0&&i>=0&&j>=0)
	{
		ans+=c[i]*p[j];
		i--;
		j--;
	}
	printf("%d",ans);
}
int main()
{
	solve();
	return 0;	
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值