PAT A1044:Shopping in Mars之二分查找

题目描述

1044 Shopping in Mars (25分)
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  • Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  • Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  • Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10^5 ), the total number of diamonds on the chain, and M (≤10^8), the amount that the customer has to pay.Then the next line contains N positive numbers D1…DN (Di ≤10^3 for all i=1,…,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj >M) minimized. Again all the solutions must be printed in increasing order of i.It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

求解思路

给定一个长度为n的非有序序列以及一个数M,要求我们给出所有满足序列和等于M的连续序列,如果不存在这样的连续序列,则要求我们输出所有满足序列和等于刚比M大的最小值的连续序列。

  • 假设有序列D1…Di…Dn,我们转换成序列sum1…sumi…sumn,其中sumi=D1+D2+…+Di。
  • 使用二分法求出第一个大于等于m的下标索引。
  • 从1到n开始遍历,然后使用二分法求得第一个大于等于m的下标索引。如果满足两个索引对应的值相减等于m,则设一个标志1,并且输出,所有满足的序列;否则,寻找大于m的最小值min。然后在标志为0的情况下,输出所以满足序列和等于min的连续序列。

实现代码(AC)

#include<cstdio>
int min=100000001;
int sum[100001]={0};
int n,m;
int flag=0;
int binary_upperbound(int index,int result)	//找到第一个大于等于result的索引j 
{
	int l=index;
	int r=n;
	while(l<r)
	{
		int mid=(l+r)/2;
		if(sum[mid]-sum[index-1]>=result)	r=mid;
		else l=mid+1;
	}
	return l;
}
void solve()
{
	scanf("%d %d",&n,&m);
	for(int i=1;i<=n;i++)
	{
		int tmp;
		scanf("%d",&tmp);
		sum[i]=sum[i-1]+tmp;
	}
	for(int i=1;i<=n;i++)
	{
		int j=binary_upperbound(i,m);
		if(sum[j]-sum[i-1]==m)	
		{
			printf("%d-%d\n",i,j);
			flag=1;
		}
		else if(sum[j]-sum[i-1]<min&&sum[j]-sum[i-1]>=m)
		{
			min=sum[j]-sum[i-1];
		}
	}
	if(!flag)
	{
		for(int i=1;i<=n;i++)
		{
			int j=binary_upperbound(i,min);
			if(sum[j]-sum[i-1]==min)
				printf("%d-%d\n",i,j);
		}
	}
}
int main()
{
	solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值