PAT A1089:Insert or Merge之插入和归并排序

题目描述

1089 Insert or Merge (25分)
According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Merge Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case.
All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

求解思路

  • 给定一个初始序列a1,以及部分排序好得到的序列a3,要求我们判断a1是根据插入排序还是归并排序得到的序列,并且最终给出下一步排序得到的序列。

代码实现(AC)

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=101;
int n;
int a1[maxn],a2[maxn],a3[maxn];
bool isSame(int a[],int b[])	//判断两个数组是否相等 
{
	for(int i=0;i<n;i++)
		if(a[i]!=b[i])	return false;
	return true;
}
void print(int a[])	//打印数组 
{
	printf("%d",a[0]);
	for(int i=1;i<n;i++)
		printf(" %d",a[i]);
	printf("\n");
}
void merge(int a[],int l1,int r1,int l2,int r2)
{
	int i=l1,j=l2;
	int temp[maxn],index=0;
	while(i<=r1&&j<=r2)
	{
		if(a[i]<=a[j])
			temp[index++]=a[i++];
		else temp[index++]=a[j++];	
	}	
	while(i<=r1)	temp[index++]=a[i++];
	while(j<=r2)	temp[index++]=a[j++];
	for(int i=0;i<index;i++)
		a[l1+i]=temp[i];
} 
void mergeSort()
{
	int step,mid,i;
	bool flag=false;
	for(step=2;step/2<=n;step*=2)
	{
		if(step!=2&&isSame(a1,a3))
			flag=true;
		for(i=0;i<n;i+=step)
		{
			mid=i+step/2-1;
			if(mid+1<n)
				merge(a1,i,mid,mid+1,min(i+step-1,n-1));
		}
		if(flag)
		{
			print(a1);
			return;
		}
	}	
}
bool insertSort()
{
	int i,j,temp;
	bool flag=false;
	for(i=1;i<n;i++)
	{
		if(i!=1&&isSame(a2,a3))
			flag=true;
		j=i;
		temp=a2[j];
		while(j>0&&a2[j-1]>temp)
		{
			a2[j]=a2[j-1];
			j--;
		}
		a2[j]=temp;
		if(flag)	return true;
	}
	return false;
}
int main()
{
	
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&a1[i]);
		a2[i]=a1[i];
	}
	for(int i=0;i<n;i++)
		scanf("%d",&a3[i]);
	if(insertSort())
	{
		printf("Insertion Sort\n");
		print(a2);
	}
	else
	{
		printf("Merge Sort\n");
		mergeSort();
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值