PAT A1080:Graduate Admission之sort排序

题目描述

1080 Graduate Admission (30分)
It is said that in 2011, there are about 100 graduate schools ready to proceed over 40,000 applications in Zhejiang Province. It would help a lot if you could write a program to automate the admission procedure.

Each applicant will have to provide two grades: the national entrance exam grade GE , and the interview grade GI . The final grade of an applicant is (GE +GI)/2. The admission rules are:

The applicants are ranked according to their final grades, and will be admitted one by one from the top of the rank list.

If there is a tied final grade, the applicants will be ranked according to their national entrance exam grade GE. If still tied, their ranks must be the same.

Each applicant may have K choices and the admission will be done according to his/her choices: if according to the rank list, it is one’s turn to be admitted; and if the quota of one’s most preferred shcool is not exceeded, then one will be admitted to this school, or one’s other choices will be considered one by one in order. If one gets rejected by all of preferred schools, then this unfortunate applicant will be rejected.

If there is a tied rank, and if the corresponding applicants are applying to the same school, then that school must admit all the applicants with the same rank, even if its quota will be exceeded.

Input Specification:
Each input file contains one test case.

Each case starts with a line containing three positive integers: N (≤40,000), the total number of applicants; M (≤100), the total number of graduate schools; and K (≤5), the number of choices an applicant may have.

In the next line, separated by a space, there are M positive integers. The i-th integer is the quota of the i-th graduate school respectively.

Then N lines follow, each contains 2+K integers separated by a space. The first 2 integers are the applicant’s GE and GI , respectively. The next K integers represent the preferred schools. For the sake of simplicity, we assume that the schools are numbered from 0 to M-1, and the applicants are numbered from 0 to N-1.

Output Specification:
For each test case you should output the admission results for all the graduate schools. The results of each school must occupy a line, which contains the applicants’ numbers that school admits. The numbers must be in increasing order and be separated by a space. There must be no extra space at the end of each line. If no applicant is admitted by a school, you must output an empty line correspondingly.

Sample Input:

11 6 3
2 1 2 2 2 3
100 100 0 1 2
60 60 2 3 5
100 90 0 3 4
90 100 1 2 0
90 90 5 1 3
80 90 1 0 2
80 80 0 1 2
80 80 0 1 2
80 70 1 3 2
70 80 1 2 3
100 100 0 2 4

Sample Output:

0 10
3
5 6 7
2 8

1 4

求解思路

  • 题意:给定参与人数n,学校数m,每个学生可以申请得学校数k;给定每个学校的可录取学生的人数。对于每个学生给定GE、GI,可以申请的k个学校的id。要求我们按照学校id开始输出该学校录取的学生的id,每个学校占用一行,如果该学校未录取人数则空着该行,已录取学生的学校按照学生id升序输出学生的id。录取采取优先录取的原则,首先录取GE+GI较高的人,如果GE+GI相等则录取GE较高的人,如果还是相等则表示两者排名相同,此时如果就算学校名额不够录取两人,也应该同时录取。
  • 解法:可以用一个结构体存储total=GE+GI,GE,GI以及vector用于存储该同学申请的学校id。用一个数组full表示该学校可以录取的学生人数,tmp表示学校已录取的学生人数,res是一个vector数组,每一个元素用于存储一个vector,即学生id。

代码实现(AC)

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
struct Student{
	int total;
	int GE;
	int GI;
	int id;
	vector<int>choice;
};
bool cmp1(Student a,Student b)
{
	if(a.total!=b.total)	return a.total>b.total;
	return a.GE>b.GE;
}
bool cmp2(Student a,Student b)
{
	return a.id<b.id;
}
int full[110]={0},tmp[110]={0};
int n,m,k;
void solve()
{
	scanf("%d %d %d",&n,&m,&k);
	for(int i=0;i<m;i++)
		scanf("%d",&full[i]);
	vector<Student>stu(n),res[110];
	for(int i=0;i<n;i++)
	{
		int ge,gi,choice;
		scanf("%d %d",&ge,&gi);
		stu[i].id=i;
		stu[i].GE=ge;
		stu[i].GI=gi;
		stu[i].total=ge+gi;
		stu[i].choice.resize(k);
		for(int j=0;j<k;j++)
		{
			scanf("%d",&choice);
			stu[i].choice[j]=choice;
		}
	}
	sort(stu.begin(),stu.end(),cmp1);
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<k;j++)
		{
			int schid=stu[i].choice[j];
			int last=tmp[schid]-1;
			if(tmp[schid]<full[schid]||((stu[i].total==res[schid][last].total)&&(stu[i].GE==res[schid][last].GE)))
			{
				tmp[schid]++;
				res[schid].push_back(stu[i]);
				break;
			}
		}
	}
	for(int i=0;i<m;i++)
	{
		sort(res[i].begin(),res[i].end(),cmp2);
		for(int j=0;j<res[i].size();j++)
		{
			printf("%d",res[i][j].id);
			if(j!=res[i].size()-1)	printf(" ");
		}
		printf("\n");
	}
}
int main()
{
	solve();
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值