poj 2632 Crashing Robots(模拟题)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11637 Accepted: 4933

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving. 
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction. 
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively. 
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position. 
 
Figure 1: The starting positions of the robots in the sample warehouse

Finally there are M lines, giving the instructions in sequential order. 
An instruction has the following format: 
< robot #> < action> < repeat> 
Where is one of 
  • L: turn left 90 degrees, 
  • R: turn right 90 degrees, or 
  • F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case: 
  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.) 
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot. 
  • OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int maxn=110;
int map[maxn][maxn];
struct Node
{
    int x,y;
    int dir;//0,1,2,3:N,E,S,E
}rob[maxn];
int mov[4][2]={{0,1},{-1,0},{0,-1},{1,0}};
int main()
{
    int t;
    int a,b,n,m;
    char str[10];
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&a,&b,&n,&m);
        memset(map,0,sizeof(map));
        for(int i=1;i<n+1;i++)
        {
            scanf("%d%d",&rob[i].x,&rob[i].y);
            map[rob[i].x][rob[i].y]=i;
            scanf("%s",&str);
            if(str[0]=='N') rob[i].dir=0;
            else if(str[0]=='W') rob[i].dir=1;
            else if(str[0]=='S') rob[i].dir=2;
            else if(str[0]=='E') rob[i].dir=3;
        }
        int t1,t2;
        bool flag=false;
        while(m--)
        {
            scanf("%d%s%d",&t1,&str,&t2);
            if(flag) continue;//已经记录第一次相撞
            if(str[0]=='L')
            {
                rob[t1].dir+=t2;
                rob[t1].dir%=4;
            }
            else if(str[0]=='R')
            {
                rob[t1].dir-=t2;
                rob[t1].dir%=4;
                rob[t1].dir=(rob[t1].dir+4)%4;//负的变成正的
            }
            else  //向前走
            {
                int x=rob[t1].x;
                int y=rob[t1].y;
                while(t2--)   //一步一步来
                {
                    x=rob[t1].x;
                    y=rob[t1].y;
                    x+=mov[rob[t1].dir][0];
                    y+=mov[rob[t1].dir][1];
                    if(x<=0||x>a||y<=0||y>b)
                    {
                        printf("Robot %d crashes into the wall\n",t1);
                        flag=true;
                        break;
                    }
                    else if(map[x][y]!=0)
                    {
                        printf("Robot %d crashes into robot %d\n",t1,map[x][y]);
                        flag=true;
                        break;
                    }
                    else
                    {
                        map[x][y]=t1;
                        map[rob[t1].x][rob[t1].y]=0;
                        rob[t1].x=x;
                        rob[t1].y=y;
                    }
                }
            }
        }
        if(!flag) printf("OK\n");
    }
    return 0;
}

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看READme.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值