POJ 2632 Crashing Robots(模拟)

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.

Figure 1: The starting positions of the robots in the sample warehouse
在这里插入图片描述

Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
L: turn left 90 degrees,
R: turn right 90 degrees, or
F: move forward one meter,

and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
Output

Output one line for each test case:
Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
OK, if no crashing occurs.

Only the first crash is to be reported.

Sample Input

4
5 4
2 2
1 1 E
5 4 W
1 F 7
2 F 7
5 4
2 4
1 1 E
5 4 W
1 F 3
2 F 1
1 L 1
1 F 3
5 4
2 2
1 1 E
5 4 W
1 L 96
1 F 2
5 4
2 3
1 1 E
5 4 W
1 F 4
1 L 1
1 F 20

Sample Output

Robot 1 crashes into the wall
Robot 1 crashes into robot 2
OK
Robot 1 crashes into robot 2

思路

模拟机器人的走动,定义一个二维数组,用于存储每一个位置的状态。机器人的方向使用角度存储。题比较简单,需要注意的地方很多。方向每一此不一定转动90度。移动位置后,原位置和之后的位置都需要改变。出了事故后,不需要操作,(此处可能造成数组越界,如一直移动到负数),只输出一次,但要继续读入数据。输出的内容,最好复制,注意空格和大小写。

代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int map[1001][1001];

struct rot									//坐标 方向 
{
	int x,y,dir;
}r[1001];

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		memset(map,0,sizeof(map));			//数据重置 
		memset(r,0,sizeof(r));
		int n,m,a,b,cnt=0;
		cin>>n>>m>>a>>b;
		for(int i=1;i<=a;i++)
		{
			int p,q;
			char d;
			cin>>p>>q>>d;
			map[p][q]=++cnt;				//地图上记录机器人的编号 
			r[cnt].x=p;
			r[cnt].y=q;
			if(d=='E') r[cnt].dir=0;
			if(d=='N') r[cnt].dir=90;
			if(d=='W') r[cnt].dir=180;
			if(d=='S') r[cnt].dir=270;
		}
		char opt;
		int num;
		bool ok=1;							//事故标记 
		for(int i=1;i<=b;i++)
		{
			cin>>cnt>>opt>>num;
			if(opt=='R')
				r[cnt].dir=(r[cnt].dir+270*num)%360;	// 不一定转动90度 
			else if(opt=='L')
				r[cnt].dir=(r[cnt].dir+90*num)%360;
			else
			{
				if(!ok)										//没有问题才进行操作 
					continue;
				map[r[cnt].x][r[cnt].y]=0;					// 动了原位置消除标记 
				if(r[cnt].dir==0)
				{
					for(int j=1;j<=num;j++)
					{
						r[cnt].x++;
						if(r[cnt].x>n)
						{
							if(ok)							// 这个条件不需要 前面判断过 下同 
								cout<<"Robot "<<cnt<<" crashes into the wall"<<endl;
							ok=0;							// 出事故了标记 后面只读入数据 不进行操作 
							break;
						}
						if(map[r[cnt].x][r[cnt].y])
						{
							if(ok)
								cout<<"Robot "<<cnt<<" crashes into robot "<<map[r[cnt].x][r[cnt].y]<<endl;
							ok=0;
							break;
						}
					}
				}
				if(r[cnt].dir==90)
				{
					for(int j=1;j<=num;j++)
					{
						r[cnt].y++;
						if(r[cnt].y>m)
						{
							if(ok)
								cout<<"Robot "<<cnt<<" crashes into the wall"<<endl;
							ok=0;
							break;
						}
						if(map[r[cnt].x][r[cnt].y])
						{
							if(ok)
								cout<<"Robot "<<cnt<<" crashes into robot "<<map[r[cnt].x][r[cnt].y]<<endl;
							ok=0;
							break;
						}
					}
				}
				if(r[cnt].dir==180)
				{
					for(int j=1;j<=num;j++)
					{
						r[cnt].x--;
						if(r[cnt].x<1)
						{
							if(ok)
								cout<<"Robot "<<cnt<<" crashes into the wall"<<endl;
							ok=0;
							break;
						}
						if(map[r[cnt].x][r[cnt].y])
						{
							if(ok)
								cout<<"Robot "<<cnt<<" crashes into robot "<<map[r[cnt].x][r[cnt].y]<<endl;
							ok=0;
							break;
						}
					}
				}
				if(r[cnt].dir==270)
				{
					for(int j=1;j<=num;j++)
					{
						r[cnt].y--;
						if(r[cnt].y<1)
						{
							if(ok)
								cout<<"Robot "<<cnt<<" crashes into the wall"<<endl;
							ok=0;
							break;
						}
						if(map[r[cnt].x][r[cnt].y])
						{
							if(ok)
								cout<<"Robot "<<cnt<<" crashes into robot "<<map[r[cnt].x][r[cnt].y]<<endl;
							ok=0;
							break;
						}
					}
				}
				map[r[cnt].x][r[cnt].y]=cnt;
			}
		}
		if(ok)
		cout<<"OK"<<endl;
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值