Expedition(贪心+优先队列)

POJ 2341-Expedition

      A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck’s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.
       To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1…100 units at each stop).
       The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).
       Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.

input

  • Line 1: A single integer, N
  • Lines 2…N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.
  • Line N+2: Two space-separated integers, L and P

output

       Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

样例输入

4
4 4
5 2
11 5
15 10
25 10

样例输出

2

样例解释

卡车离城镇有25个单位,卡车有10个单位的燃料。沿途有4个燃料站,距离城镇4、5、11和15(因此这些燃料站最初距离卡车21、20、14和10)。这些燃料停止器可以分别供应高达4, 2, 5和10单位的燃料。
驱动10个单位,停下来获取10个单位的燃料单元,驱动4个的单位,停下来获取更多的5个单位的燃料,然后到达镇上.

#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
bool cmp(pair<int,int> A, pair<int, int>  B) {
	return A.first < B.first;
}
int main() {
	int n;
	cin >> n;
	pair<int, int>p[10005];
	priority_queue<int>q;//优先队列
	for (int i = 0; i < n; i++) 
		cin >> p[i].first>>p[i].second;
	int len, oil;
	cin >> len >> oil;
	for (int i = 0; i < n; i++)
		p[i].first = len - p[i].first;//处理数据让从卡车的起点到加油站的位置.
	sort(p, p + n, cmp);//排序
	//方便处理,认为小镇也是加油站
	p[n].first = len;
	p[n].second = 0;
	int s = 0, ant = 0;
	//s:现在的位置,ant:加油次数
	for (int i = 0; i <= n; i++) {
		int d = p[i].first - s;
		while (oil-d<0){//判断油是否够用,如果够用就不加油
			if (q.empty()) {
				cout << "-1" << endl;
				return 0;
			}
			oil += q.top();
			ant++;
			q.pop();
		}
		oil -= d;
		s = p[i].first;
		q.push(p[i].second);
	}
	cout << ant << endl;
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值