POJ-2431的题解

题目:Expedition

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels.

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input
* Line 1: A single integer, N

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.

* Line N+2: Two space-separated integers, L and P
Output
* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4
4 4
5 2
11 5
15 10
25 10
Sample Output
2
Hint

INPUT DETAILS:

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively.

OUTPUT DETAILS:

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.


港真一开始确实没想到合适的算法……看了《挑战》75页的思路提示,然后自己实现的。我们应该可以想到去选择目前可行走范围内油量最多的加油站,但怎么知道用不用在第二多第三多的油站停靠呢?不必刻意停靠加油,只要油箱里的油还够用就接着走,但把路过的油站保留在优先队列中,一旦油箱的油量不足以到达下一站点时就取priority_queue.top()的油加上,大概就是延迟使用的道理。只借鉴了思路,由于笔者是green hand,代码难免有冗余、不足之处,欢迎指出。代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;
struct node//若干个加油站 
{
	int distance,fuel; 
	bool operator <(const node &b)const//用于定义优先队列的优先度 
	{
		return fuel<b.fuel;
	}
}a[10005];

bool cmp(node a,node b)
{
	return a.distance<b.distance;
}
//n个加油站;到达town的距离;目前油量(此处只增不减,没去掉已走距离);需要加油的站点数(即答案) 
int n,town,nowfuel,ans;
priority_queue<node>q;//以油量多为优先 

int main()
{
	cin>>n;
	
	for(int i=1;i<=n;i++)
		scanf("%d%d",&a[i].distance,&a[i].fuel);
		
	cin>>town>>nowfuel;
	
	for(int i=1;i<=n;i++)//题目中先给的到终点距离后给的终点,所以求了一遍到起点距离 
		a[i].distance=town-a[i].distance;
		
	sort(a+1,a+1+n,cmp);//按到起始点距离从小到大排 
	a[n+1].distance=town;//把终点也设为一个站点就可以在循环里跟着判断,不用单拿出来在最后判断了 
	
	for(int i=1;i<=n+1;i++)//一个一个站点搜,看能不能到达 
	{		
		while(a[i].distance>nowfuel)//如果油量不够到达 
		{
			if(q.empty())//前面没有加油站可加了,死活也到不了了 
			{
				cout<<-1;
				return 0;
			}
			nowfuel+=q.top().fuel;
			ans++;
			q.pop();
		}
		//if(a[i].distance<=nowfuel)
			q.push(a[i]);
	}
	cout<<ans;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值