2940: 结构体变量的使用。

时间限制: 1 Sec   内存限制: 128 MB
提交: 526   解决: 359
[ 提交][ 状态][ 讨论版]

题目描述

定义一个结构体变量,输入数据,输出变量内容。主函数在程序的最后并且已给出,提交程序的其他部分即可。

int main()
{
       student student1;
       cin>>student1.num>>student1.name>>student1.sex>>student1.score;
       cout<<student1.num<<' '<<student1.name<<' '<<student1.sex<<' '<<student1.score;
       return 0;
}

输入

结构体变量的数据。

输出

结构体变量各成员值。

样例输入

1001 lihong f 89.7

样例输出

1001 lihong f 89.7

提示

来源

tanzheng


代码:

#include<iostream>
using namespace std;
struct student
{
int num;
char name[20];
char sex;
float score;
};
int main()


{


       student student1;


       cin>>student1.num>>student1.name>>student1.sex>>student1.score;


       cout<<student1.num<<' '<<student1.name<<' '<<student1.sex<<' '<<student1.score;


       return 0;


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值