【题解】 HDU 1492 The number of divisors(约数) about Humble Numbers

目录

 

题目描述

题意分析

AC代码


题目描述

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

Input

The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

Output

For each test case, output its divisor number, one line per case.

Sample Input

4 12 0

Sample Output

3 6

 

题意分析

题意:给你一个64位的整数,要你求其约数。64位很大,long long 是一个WA点,然后根据数论知识,

           唯一分解定理,一个大于1的自然数,必能被拆分为质数的乘积。那么其约数就是所得(质数+1)的乘积

 

AC代码

#include <iostream>
#include <algorithm>
#include <memory.h>
using namespace std;
typedef long long LL;

LL s[4];

LL solve(LL n)
{
    int i;
    LL sum=1;
    memset(s,0,sizeof(s));
    for(i=0;n%2==0;i++)
    {
        s[0]++;
        n/=2;
    }
    for(i=0;n%3==0;i++)
    {
        s[1]++;
        n/=3;
    }
    for(i=0;n%5==0;i++)
    {
        s[2]++;
        n/=5;
    }
    for(i=0;n%7==0;i++)
    {
        s[3]++;
        n/=7;
    }

    for(i=0;i<4;i++)
    {
        sum *= s[i]+1;
    }
    return sum;
}

int main()
{
    LL n,sum;
    while(cin>>n && n)
    {
        sum = solve(n);
        cout<<sum<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值