hdu1492 The number of divisors(约数) about Humble Numbers(公约数个数问题)


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

 

Input
The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.
 

Output
For each test case, output its divisor number, one line per case.
 

Sample Input
  
  
4 12 0
 

Sample Output
  
  
3 6
题意:给出一个只包含质因数2,3,5,7的数,求其公约数的个数
思路:如果n=p1^n1*p2^n2*...*pn^nn,其中p1,p2,...,pn表示质因数,n1,n2,...,nn表示相应质因数的指数,则公约数的个数为(n1+1)(n2+1)...(nn+1)
用java实现总是内存超过限制,改用c++实现,vs2013中用非安全的scanf会提示出错,代码中添加了忽略:#pragma warning(disable:4996)
代码如下
#include <cstdio>

using namespace std;

#pragma warning(disable:4996)

typedef long long LL;

LL f[4];
LL n;

bool input()
{
	scanf("%lld", &n);
	if (n == 0) return false;

	return true;
}



void solve()
{
	f[0] = 1;

	while (n % 2 == 0) {
		f[0]++;
		n /= 2;
	}
	 
	f[1] = 1;
	while (n % 3 == 0) {
		f[1]++;
		n /= 3;
	}

	f[2] = 1;
	while (n % 5 == 0) {
		f[2]++;
		n /= 5;
	}

	f[3] = 1;
	while (n % 7 == 0) {
		f[3]++;
		n /= 7;
	}

	LL ans = f[0] * f[1] * f[2] * f[3];

	printf("%lld\n", ans);
}

int main()
{
#ifndef ONLINE_JUDGE
	freopen("f:\\OJ\\uva_in.txt", "r", stdin);
#endif

	while (input()) {
		solve();
	}

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值