HDU 1879 继续畅通工程

继续畅通工程

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。  
Input测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。  

当N为0时输入结束。Output每个测试用例的输出占一行,输出全省畅通需要的最低成本。Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
Sample Output
3
1
0

 

只需要将已经修建的路的费用变成0 ,便是一颗裸最小生成树了
代码入下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctime>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<string>
#include<queue>
#include<vector>
#include<stack>
#include<list>
using namespace std;
struct node
{
    int u,v,w;
    bool operator <( const node &a)
    {
        return w<a.w;
    }
} s[101*50];
int pre[105];
int Find(int x)
{
    return x==pre[x]?x:pre[x]=Find(pre[x]);
}
int main()
{
    int n,i;
    while(scanf("%d",&n),n)
    {
        int m=n*(n-1)/2;
        int fg;
        for(i=0; i<m; i++)
        {
            scanf("%d %d %d %d",&s[i].u,&s[i].v,&s[i].w,&fg);
            if(fg==1) s[i].w=0;
        }
        for(i=0;i<=n;i++)
            pre[i]=i;
        sort(s,s+m);
        int sum=0;
        for(i=0;i<m;i++)
        {
            int fx=Find(s[i].u),fy=Find(s[i].v);
            if(fx!=fy)
            {
                  pre[fx]=fy;
                  sum+=s[i].w;
            }
        }
        cout<<sum<<endl;

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值