HDU 4496 D-City 删边并查集

一、内容

 Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly. 

Input

First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input

5 10 
0 1 
1 2 
1 3 
1 4 
0 2 
2 3 
0 4 
0 3 
3 4 
2 4

Sample Output

1 
1 
1 
2 
2 
2 
2 
3 
4 
5

二、思路

  • 删除边难,那么就转换为建边即可。 从后面往前面进行建边。

三、代码

#include <cstdio>
#include <cstring>
using namespace std;
const int N = 1e4 + 5, M = 1e5 + 5;
int n, m , p[N], ans[M], u[M], v[M];
int find(int x) {return x == p[x] ? x : (p[x] = find(p[x]));}
int main() {
	while (~scanf("%d%d", &n, &m)) {
		for (int i = 1; i <= m; i++) scanf("%d%d", &u[i], &v[i]);
		for (int i = 0; i <= n; i++) p[i] = i;
		for (int i = m; i >= 1; i--) {
			ans[i] = n;
			int fu = find(u[i]), fv = find(v[i]);
			if (fu != fv) {
				p[fu] = fv;
				n--;
			}
		} 
		for (int i = 1; i <= m; i++) printf("%d\n", ans[i]);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值