【FZU - 2140 】Forever 0.5 (计算几何,构造)

题干:

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

Sample Input

3
2
3
5

Sample Output

No
No
Yes
0.000000 0.525731
-0.500000 0.162460
-0.309017 -0.425325
0.309017 -0.425325
0.500000 0.162460

Hint

This problem is special judge.

题目大意:

给你一个数n,让你找出n个点,满足一下关系:

  • 任意两点的距离不大于1.0
  • 所有点到原点的距离不大于1.0
  • 恰好有N对点的距离为1.0
  • 由这些点构成的n边形的面积不小于0.5
  • 由这些点构成的n边形的面积不大于0.75

解题报告:

           因为点可以重复嘛对吧所以干脆都输出那同一个点好了。。。

AC代码:

#include<cstdio>
#include<cmath>
#include<iostream>
using namespace std;
const int maxn = 35;
int main() 
{
	int t,n;
	cin>>t;
	while(t--) {
		scanf("%d", &n);
		if (n <= 3) printf("No\n");
		else {
			printf("Yes\n");
			printf("0 0\n");
			printf("-0.5 %.6lf\n",sqrt(3.0) / 2);
			printf("0.5 %.6lf\n",sqrt(3.0) / 2);
			for (int i = 4; i <= n; i++) {
				printf("%.6lf %.6lf\n",0.0,1.0);
			}
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值