【POJ - 2262】Goldbach's Conjecture (数论,哥德巴赫猜想,知识点结论)

123 篇文章 1 订阅
92 篇文章 11 订阅

题干:

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 

Every even number greater than 4 can be 
written as the sum of two odd prime numbers.


For example: 

8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.


Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

题目大意:

     给定一个大于4的数num,求两个奇素数使得num = p1 + p2.

解题报告:

    当时写的代码太丑陋了23333.

其实这一性质可以当一个结论去记住。。。给定一个大于4的偶数num,求两个奇素数使得num = p1 + p2.

不难分析出给出的num一定是个偶数(因为奇+奇=偶)。另外我们只需要从小到大遍历其中一个,然后看另一个是否在里面就可以了,不需要双重循环。因为我们通过其中一个,和num,就可以推断出另一个是多少,所以不需要在进行一轮循环,做了很多无用的操作。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#define MAX 1000001//求MAX范围内的素数 
using namespace std;  
 
long long su[MAX],cnt;  
bool isprime[MAX];  
void prime()  
{  
    cnt=1;  
    memset(isprime,1,sizeof(isprime)); 
    isprime[0]=isprime[1]=0;
    for(long long i=2;i<=MAX;i++)  
    {  
        if(isprime[i]) {
            su[cnt++]=i; 
        } 
        for(long long j=1;j<cnt&&su[j]*i<MAX;j++)  
        {  
            isprime[su[j]*i]=0;
        }  
    }  
}  
int main()
{
	prime();
	int n;
	int i,flag; 
	while(scanf("%d",&n) && n ) {
		flag = 0;
		for( i= 3; i+i<=n; i+=2) {
			if(isprime[ i ] == 1 && isprime[n-i] == 1) {
				flag = 1;
				break;
			}
		}
		if(flag == 1) {
				printf("%d = %d + %d\n",n,i,n-i);
			}
			else {
				printf("Goldbach's conjecture is wrong.\n");
			}
		
		
	}
	
	return 0 ;
 } 

但是为什么这样会WA?

#include<cstdio>
#include<cstring>
#include<iostream>
#define MAX 1000001
using namespace std;  
 
long long su[MAX],cnt;  
bool isprime[MAX];  
void prime()  
{  
    cnt=1;  
    memset(isprime,1,sizeof(isprime)); 
    isprime[0]=isprime[1]=0;
    for(long long i=2;i<=MAX;i++)  
    {  
        if(isprime[i]) {
            su[cnt++]=i; 
        } 
        for(long long j=1;j<cnt&&su[j]*i<MAX;j++)  
        {  
            isprime[su[j]*i]=0;
        }  
    }  
}  
int main()
{
	prime();
	int n;
	int i,flag; 
	while(cin>>n)  {
		flag = 0;
		for( i= 2; su[i]<=n; i++) {
			if(isprime[ n - su[i] ] == 1) {
				flag = 1;
				break;
			}
		}
		if(flag == 1) {
				printf("%d = %lld + %lld\n",n,su[i],n-su[i] );
			}
			else {
				printf("Goldbach's conjecture is wrong.\n");
			}
		
		
	}
	
	return 0 ;
 }

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值