Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS:
There are five landmarks.
OUTPUT DETAILS:
Bessie can get home by following trails 4, 3, 2, and 1.
题目大意:
说的是,一只奶牛位于N号节点,输入N个节点和T对双向的边,求出由N到1的最短的距离,其实就是问的单源最短路问题,首先想到了Dijkstra算法。
代码:
#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<map>
#include<queue>
#include<set>
#include<cmath>
#include<stack>
#include<string>
const int maxn=1e4+10;
const int mod=1e9+7;
const int inf=1e8;
#define me(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
int n;
struct node
{
int y,w;
node(int y1,int w1):y(y1),w(w1){}
};
vector<node>mp[maxn];
int Dij()
{
bool vis[maxn];me(vis,0);
int d[maxn];fill(d,d+maxn,inf);
d[n]=0;
for(int i=1;i<=n;i++)
{
int mi=inf,u=-1;
for(int j=1;j<=n;j++)
if(d[j]<mi&&!vis[j])
mi=d[j],u=j;
vis[u]=1;
for(int j=0;j<mp[u].size();j++)
{
int v=mp[u][j].y;
if(!vis[v]&&d[u]+mp[u][j].w<d[v])
d[v]=d[u]+mp[u][j].w;
}
}
return d[1];
}
int main()
{
int t;
cin>>t>>n;
me(mp,0);
for(int i=0;i<t;i++)
{
int x,y,w;scanf("%d%d%d",&x,&y,&w);
mp[x].push_back(node(y,w));
mp[y].push_back(node(x,w));
}
cout<<Dij()<<endl;
return 0;
}