HDU 1068 Girls and Boys(二分匹配)

 

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13335    Accepted Submission(s): 6262


 

Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

 

Sample Input

7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0

 

Sample Output

5

2

PS:题意就是学校里现在有n个学生,其中有些之间有暧昧关系,求最大男女没有关系的个数,这个题并没有给出那个是男的,哪个是女的,所以最后求出最大匹配数要除以2。最大独立集=顶点数-最大匹配数。

AC代码:

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
#include<cmath>
#include<vector>
const int maxn=1e3+5;
const int mod=1e9+7;
const int inf=1e9;
#define me(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
int n,d[maxn];
bool vis[maxn];
vector<int>maps[maxn];
int found(int x)
{
    for(int i=0;i<maps[x].size();i++)
    {
        int u=maps[x][i];
        if(!vis[u])
        {
            vis[u]=1;
            if(d[u]==-1||found(d[u]))
            {
                d[u]=x;
                return 1;
            }
        }
    }
    return 0;
}
int hungry()
{
    me(d,-1);int sum=0;
    for(int i=0;i<n;i++)
    {
        me(vis,0);
        sum+=found(i);
    }
    return sum;
}
int main()
{
    while(~scanf("%d",&n))
    {
        me(maps,0);
       for(int i=0;i<n;i++)
       {
           int x,m;
           scanf("%d: (%d)",&x,&m);
           while(m--)
           {
               int y;scanf("%d",&y);
               maps[x].push_back(y);
               maps[y].push_back(x);
           }
       }
       cout<<n-hungry()/2<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值