1141 PAT Ranking of Institutions (25 分)

After each PAT, the PAT Center will announce the ranking of institutions based on their students' performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

题目大意:给出学生id,分数,学校(不区分大小写,tolower转一下即可),让你输出排名。格式:rank~学校~加权总分~人数。

排名加权总分降序,若相同按人数升序,再相同则按校名升序。

分析:结构体排序

1)要想排序,只要得到该学校对应的人数 && 加权总分

定义map<string,double>totalsum记录学校加权成绩, map<string,int>cnt记录学校总人数(unordered快一点)

2)输出:
定义vector<node>v保存输出,迭代器it访问cnt ,把相应的属性v.push_back({ }),然后对v排序输出即可。

注意:加权成绩要定义成double,最后输出转int。直接定义int会有一个测试点错误。

AC代码:

#include<bits/stdc++.h> 
using namespace std;
struct node{
	string id;
	int tws,ns;
	bool operator <(const node& a)const{
		if(tws!=a.tws) return tws>a.tws;
		else if(ns!=a.ns) return ns<a.ns;
		else return id<a.id;
	}
};

int main(){
	//freopen("1.txt","r",stdin);
	int n;
	cin>>n;
	map<string,int>totalsum;
	map<string,int>cnt;
	for(int i=0;i<n;i++){
		string id,school;
		int score;
		cin>>id>>score>>school;
		if(id[0]=='B') score/=1.5;
		else if(id[0]=='T') score*=1.5;
		for(int j=0;j<school.length();j++){
			school[j]=tolower(school[j]);
		}
		totalsum[school]+=score;
		cnt[school]++;
	}
	vector<node>v;
	for(auto it=cnt.begin();it!=cnt.end();it++)
		v.push_back({it->first,(int)totalsum[it->first],cnt[it->first]});
	sort(v.begin(),v.end());
	cout<<v.size()<<"\n";
	int pre=v[0].tws;//记录上一个学校加权总分 
	int rank=1;
	for(int i=0;i<v.size();i++){
		if(pre!=v[i].tws) rank=i+1;
		printf("%d %s %d %d\n",rank,v[i].id.c_str(),v[i].tws,v[i].ns);
		pre=v[i].tws;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值