1127 ZigZagging on a Tree (30 point(s)) (中序、后序建树and dfs深搜)

1127 ZigZagging on a Tree (30 point(s))

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题目大意:给一个后序和中序序列,让你进行S形遍历输出

分析:1)  后序和中序建树(各种建树考频也太高了)

           2)dfs中序深度递归(刚好符合从左到右或从右到左的顺序),用邻接表结构保存每一层结点

           3)输出

#include<bits/stdc++.h>
using namespace std;
const int maxn=31;
struct node{
	int data;
	node *l,*r;
}; 
int post[maxn],in[maxn],n;

node *creat(int postl,int postr,int inl,int inr){
	if(postl>postr){
		return NULL;
	}
	node *root=new node;
	root->data=post[postr];  
	int k;
	for( k=inl;k<=inr;k++){
		if(in[k]==post[postr])
		break;
	}  
	int leftnum=k-inl;
	root->l =creat(postl,postl+leftnum-1,inl,k-1);
	root->r =creat(postl+leftnum,postr-1,k+1,inr);
	return root;
}
int maxdepth=0;
vector<int>v[100];
void dfs(node *root,int depth){
	if(!root){
		maxdepth=max(depth,maxdepth);
		return ;
	}
	dfs(root->l,depth+1);
	v[depth].push_back(root->data); 
	dfs(root->r,depth+1);
}

int main(){
	cin>>n;
	for(int i=0;i<n;i++) cin>>in[i];
	for(int i=0;i<n;i++) cin>>post[i];
    //这里太坑了,题目给的后序和中序序列,然后我就想当然的以为先读后序再读入中序,所以题目要看清
	node *root=creat(0,n-1,0,n-1);
	dfs(root,0); 
//	cout<<maxdepth<<endl;
	cout<<root->data;
	for(int i=1;i<maxdepth;i++){
		if(i%2){
			for(int j=0;j<v[i].size();j++){
				cout<<" "<<v[i][j];
		    }
		}else{
			for(int j=v[i].size()-1;j>=0;j--){
				cout<<" "<<v[i][j];
		    }
		}
	}
	cout<<endl;
	return 0;
}

上一篇:层次遍历和后序遍构建二叉树

https://blog.csdn.net/qq_41317652/article/details/89076885

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值