1127 ZigZagging on a Tree (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15

层序遍历逐层翻转

#include<bits/stdc++.h>
using namespace std;
struct TreeNode {
	int val;
	TreeNode* left, * right;
	TreeNode(int x) :val(x), left(NULL), right(NULL) {}
};
TreeNode* build(int il, int ir, int pl, int pr, vector<int>& inorder, vector<int>& postorder){
	if (il > ir || pl > pr)
		return NULL;
	TreeNode* root = new TreeNode(postorder[pr]);
	int inroot = il;
	for (; inorder[inroot] != root->val; inroot++);
	root->left = build(il, inroot - 1, pl, pl + inroot - il - 1, inorder, postorder);
	root->right = build(inroot + 1, ir, pl + inroot - il, pr - 1, inorder, postorder);
	return root;
}
int main()
{
	int n,i=1;
	cin >> n;
	vector<int>inorder(n), postorder(n),ret;
	for (int i = 0; i < n; i++)
		cin >> inorder[i];
	for (int i = 0; i < n; i++)
		cin >> postorder[i];
	TreeNode* root = build(0, n - 1, 0, n - 1, inorder, postorder);
	queue<TreeNode*>que;
	que.push(root);
	while (!que.empty()){
		int num = que.size();
		vector<int>tmp;
        for(;num--;que.pop()){
			auto top = que.front();
			tmp.push_back(top->val);
			if (top->left) que.push(top->left);
			if (top->right) que.push(top->right);
		}
		if (i++ % 2)
			reverse(tmp.begin(), tmp.end());
		ret.insert(ret.end(), tmp.begin(), tmp.end());
	}
	for (int i = 0; i < ret.size(); i++)
		cout << (i == 0 ? "" : " ") << ret[i];
	return  0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值