1102 Invert a Binary Tree (25 point(s))

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题目大意;给一颗二叉树让你反转,然后输出反转后二叉树的层次遍历和先序遍历序列。

分析:

(1)题目给的结点编号的关系,所以采用静态存储。处理输入时,遇见 '-' ,即为叶子结点,记为 root【】= -1即可

(2)开一个数组找根结点,读输入数据时进行标记即可,没标记的元素下标就是根节点。

(3)后序或者先序反转二叉树。

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int N=20;
int n; bool root[N];
struct node{
	int l,r;
}node[N];

int strtonum(char c){
	if(c=='-') return -1;	
	else{
		root[c-'0']=true; //标记为非跟节点,即为孩子节点 
		return c-'0';	
	}	
}

int find(){
	for(int i=0;i<n;i++){
		if(!root[i]){
			return i;
		}
	}
}
void invert(int root){
	if(root==-1) return ;
	invert(node[root].l );
	invert(node[root].r );
	swap(node[root].l,node[root].r );
}
int cnt=0;
void vis(int root){
    cout<<root;
	cnt++;
	if(cnt<n) cout<<" ";
	else cout<<endl;
}

void inorder(int root){
	if(root==-1) return ;
	inorder(node[root].l);
	vis(root);
	inorder(node[root].r);
}

void BFS(int root){
	queue<int>q;
	q.push(root);
	while(!q.empty()){
		int now =q.front();
		q.pop();
		vis(now);
		if(node[now].l!=-1) q.push(node[now].l);
		if(node[now].r!=-1) q.push(node[now].r);
	}
}

int main(){ 
	cin>>n;
	for(int i=0;i<n;i++){
		char l,r;
		getchar();
		scanf("%c %c",&l,&r);
		node[i].l=strtonum(l);
		node[i].r=strtonum(r);		
	}
	int root=find();
	invert(root);	
	BFS(root);
	cnt=0;
        inorder(root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值