PAT 甲级 1069 The Black Hole of Numbers (20 分) 我的思路+别人思路

1069 The Black Hole of Numbers (20 分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

我的代码提交上去是19分,第五个测试点过不了,看了别人的博客,这题说的是直到差值是6174.  说是输入是6174时也要输出,也要输出等式,而非一个值,需要先执行循环体,所以用do while。

#include<iostream>
#include<algorithm>
using namespace std;
int cmp(int x,int y)
{
	return x>y;
}
int toArray(int n,int *a)
{
	int f=1;
	a[0]=n/1000;
	a[1]=n/100-a[0]*10;
	a[2]=n/10-a[0]*100-a[1]*10;
	a[3]=n%10;
	for(int i=1;i<4;i++)
	if(a[0]!=a[i])
	f=0;
	return f;
} 
int toInt(int *a)
{
	int m=0,i=0;
	for(i=0;i<4;i++)
	m=m*10+a[i];
	return m;
}
int main()
{
	int a[4]={0};
	int i,j,n,temp1=0,temp2=0;
	scanf("%d",&n);
	temp1=toArray(n,a);

	if(temp1)
	printf("%04d - %04d = 0000\n",n,n);
	else
	{
		do
		{
			sort(a,a+4,cmp);
			temp1=toInt(a);
//			printf("%d\n",temp1);
			sort(a,a+4);
			temp2=toInt(a);
//			printf("%d\n",temp2);
			n=temp1-temp2;
			printf("%04d - %04d = %04d\n",temp1,temp2,n);
			toArray(n,a);
		}
		while(n!=6174);
	}
	return 0;
}

再看看别人简洁的代码:

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
	int num, num1, num2;
	scanf("%d", &num);
	do {
		vector<int> digit;
		for (int i = 0; i < 4; i++) {
			digit.push_back(num % 10);
			num /= 10;
		}
		sort(digit.begin(), digit.end());
		num1 = digit[0] + digit[1] * 10 + digit[2] * 100 + digit[3] * 1000;
		num2 = digit[3] + digit[2] * 10 + digit[1] * 100 + digit[0] * 1000;
		num = num1 - num2;
		printf("%04d - %04d = %04d\n", num1, num2, num);
	} while (num !=0 && num!= 6174);

}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值