1140 Look-and-say Sequence (20分) 模拟题 我的代码+别人的快慢指针法

1140 Look-and-say Sequence (20分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

模拟题

遇到了一个bug

少加了这两行

str+=t;
	str+=char(cnt+'0');

统计到最后,没有把最后一次统计的加上

这个bug和大数加法最后加进位的道理类似

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
string count(string s){
	int i,j,cnt=0,len=s.length();
	char t=s[0];
	string str;
//	cout<<"s:"<<s<<endl;
//	cout<<s.length()<<endl;
	for(i=0;i<len;){
		
		if(s[i]==t){
			cnt++;
			i++;
		}
		else{
//			cout<<t<<endl;
			str+=t;
			str+=char(cnt+'0');
			cnt=1;
			t=s[i];
			i++;
		}
	}
	str+=t;
	str+=char(cnt+'0');
//	cout<<"str:"<<str<<endl;
	return str;
}
int main(){
	int n,i;
	string s,p;
//	std::ios::sync_with_stdio(false);
//	std::cin.tie(0);
//	freopen("1140test.txt","r",stdin);
	cin>>s>>n;
//	cout<<s<<"  "<<n<<endl;
	for(i=0;i<n-1;i++){
		p=count(s);
//		cout<<p<<endl;
		s=p;
	}
	cout<<s<<endl;
	return 0;
}

别人的代码:

#include<iostream>
#include<string>
using namespace std;
int main() {
	string s; int n;
	cin >> s >> n;
	while (--n) {
		string temp;
		int i, j;
		for (i = 0; i < s.size(); i=j) {
			for (j = i; j < s.size()&&s[i]==s[j]; j++);
			temp += s[i]; temp += j - i + '0';
		}
		s = temp;
	}
	cout << s;
	return 0;
}

这个用的是快慢指针法

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值