1151 LCA in a Binary Tree (30分) 测试点 2

1151 LCA in a Binary Tree (30分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

因为这题时间限制为1000ms,我半信半疑的建树,果然超时,22分

然后看了柳诺的博客。get了。

测试点2 是输入同样的数 ,让你判断。

只需要知道知道中序遍历中的根节点所在的位置,就行,

   分为三种情况:

      1.  U和V分别在根节点左右两侧,则根节点即为LCA

      2.  U、V其中一个等于根节点,则根节点为LCA,此时 U V 其中一个是另一个的LCA。

      3. U V在根节点的同一侧,递归下去。

#include<iostream>
#include<cstdio>
#include<unordered_map>
#include<vector>
#include<algorithm>
using namespace std;
#define ra 10005
int n,m,in[ra],pre[ra],f;
unordered_map<int,int> s;
void find(int preL,int inL,int inR,int t1,int t2){
    if(inL>inR)
        return ;
    else{
        int i,j,k=s[pre[preL]],k1,k2;
        k1=s[t1];
        k2=s[t2];
//        cout<<k1<<"  "<<k2<<"   "<<k<<endl;
        if(k1<k&&k<k2||k<k1&&k>k2){
            f=in[k];
            return ;
        }
        else
        if(k==k1||k==k2){
            f=in[k];
            return ;
        }
        else
        if(k1<k&&k>k2){  //左子树
            find(preL+1,inL,k-1,t1,t2);
        }
        else
        if(k<k1&&k<k2){
            find(preL+k-inL+1,k+1,inR,t1,t2);
        }
    }
}
int main(){
    int i,j,t1,t2;
    std::ios::sync_with_stdio(false);
    std::cin.tie(0);
    std::cout.tie(0);
    scanf("%d %d",&m,&n);
    for(i=0;i<n;i++){
        scanf("%d",&in[i]);
        s[in[i]]=i;
    }
    for(i=0;i<n;i++){
        scanf("%d",&pre[i]);
    }
    for(i=0;i<m;i++){
        scanf("%d %d",&t1,&t2);
        if(s.count(t1)==0&&s.count(t2)==0){
            printf("ERROR: %d and %d are not found.\n",t1,t2);
        }
        else
        if(s.count(t1)==0&&s.count(t2)==1){
            printf("ERROR: %d is not found.\n",t1);
        }
        else
        if(s.count(t1)==1&&s.count(t2)==0){
            printf("ERROR: %d is not found.\n",t2);
        }
        else{
            if(t1==t2){     //测试点2是 输入一样的数字。
                printf("%d is an ancestor of %d.\n",t1,t2);
                continue;
            }
            find(0,0,n-1,t1,t2);
            if(f!=t1&&f!=t2){
                printf("LCA of %d and %d is %d.\n",t1,t2,f);
            }
            else
            if(f==t1&&f!=t2){
                printf("%d is an ancestor of %d.\n",f,t2);
            }
            else
            if(f==t2&&f!=t1){
                printf("%d is an ancestor of %d.\n",f,t1);
            }
            f=-1;
        }
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值