PAT 甲级 1073 Scientific Notation (20 分) 科学计数法

1073 Scientific Notation (20 分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

我的代码:

主要是移动小数点。看代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
	string a,x,z,c="";
	int i,j,k,f=0,e_f=-1,len;
	int t=0;
	cin>>a;
	if(a[0]!='+')     //先处理符号 
	printf("-");
	e_f=a.find('E');     //  找到 E 的下标 
	len=a.length();
	if(a[e_f+1]=='+')    //   判断指数的正负 
	f=1;
	for(i=e_f+2;i<len;i++)   //  处理指数 ,t为需要移动几位 
	{
		t=t*10+(a[i]-'0');
	}
	if(f==1)          // 指数为正 
	{
		int flag=a.find('.');   //找到.的下标 
		for(i=1;i<e_f;i++)
		{
			if(a[i]!='.')
			{
				cout<<a[i];
			}
			if(i>flag)  // 从小数点之后起,开始移动 
			t--;
			if(t==0&&i!=e_f-1)  // 末尾不能输出. 
			cout<<'.';
		}
		while(t>0)   //输出多余的0,这应该写成t>0,而不是t!=0,这被坑过 
		{
			cout<<'0';
			t--;
		}	
	}
	else    // 小数点向前移动 
	{
		cout<<"0.";
		for(i=0;i<t-1;i++)
		cout<<'0';
		for(i=1;i<e_f;i++)
		if(a[i]!='.')
		cout<<a[i];
	}
	cout<<endl;
	return 0;
}

别人的代码:

#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
using namespace std;
 
int main(){
	string s, ans = "";
	getline(cin, s);
	if (s[0] == '-')
		ans += s[0]; // 负数前面才加负号
	int indexE = s.find("E");
	string num = s.substr(1, indexE-1);
	char x = s[indexE + 1];
	string exp = s.substr(indexE+2, s.size() - indexE - 2);
	stringstream ss;
	ss << exp;
	int e;
	ss >> e;
	if (e == 0){ // 指数为0直接输出
		cout << ans << num << endl;
		return 0;
	}
	if (x == '+'){ // 正指数的情况
		if (e < num.size() - 2){ // num.size()-2是减去小数点和1以后的部分,如果指数达不到,需要在合适的地方加小数点。
			ans = ans + num[0] + num.substr(2, e) + "." + num.substr(e + 2, num.size() - e - 2);
		}
		else{ // num.size()-2如果和指数相当,则需要补充0来扩大数字。
			ans = ans + num[0] + num.substr(2, num.size()-2);
			for (int i = 0; i < e - num.size() + 2; i++)
				ans += "0";
		}
	}
	if (x == '-'){ // 负指数的情况,需要前补0,0.算作一次指数,因此指数减到1就应该停止前补0.
		ans = ans + "0.";
		while (e-- != 1)
			ans += "0";
		ans = ans + num[0] + num.substr(2, num.size()-2);
	}
	cout << ans << endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值