POJ - 2096 Collecting Bugs

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

 

题目长的要死,大概就是有s个子系统,有n种bug。某人每天随机从一个子系统里找一个bug,问找完所有bug的期望。

这应该是我第一次认真做概率dp。总的来说,求概率的需要从前往后推,求期望的需要从后往前推:显而易见,第一次的概率是已知的,最后一次的期望也是已知的,根据题意为0或者是啥的。

显然,dp[i][j]有四种转移方式:dp[i][j](同系统同bug),dp[i+1][j+1](新系统新bug),dp[i+1][j](同系统新bug),dp[i][j+1](新系统同bug),他们的概率分别为i*j / (n*s),(n-i)*j / (n*s),i*(s-j) / (n*s),(n-i)*(s-j) / (n*s)。

而期望可以分解为子期望的加权和,这也是递推求期望的基础。很容易知道d[n][s]为0,即找到所有系统的所有bug以后不需要再花天数找bug,以此往前推就行,注意式子要化简,不然会损失精度。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

 double dp[1010][1010];

int main()
{
    int n,s,ns;
    cin>>n>>s;
    ns=n*s;
    dp[n][s]=0.0;
    for(int i=n;i>=0;i--)
        for(int j=s;j>=0;j--)
        {
            if(i==n&&j==s)
                continue;
            dp[i][j]=(ns+(n-i)*j*dp[i+1][j]+i*(s-j)*dp[i][j+1]+(n-i)*(s-j)*dp[i+1][j+1])/(ns-i*j);
        }

    printf("%.4lf\n",dp[0][0]);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值