POJ - 3071 Football

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After nrounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.

The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

给你2^n只足球队和他们战胜另外队伍的概率,让他们两两比赛,胜者再两两比赛(大概有个学名?),求胜率最高的队伍。

这道题很贴心的给了提示,看完提示像我这样的弟弟大概也能想到dp方法了:dp[i][j]表示第i轮第j只队伍的胜率,转移方程为dp[i][j]=dp[i][j]=dp[i-1][j]*sum,sum为和其他所有可能比赛的队伍胜率之和,即\sumdp[i-1][k]*p[j][k]。那么这道题的主要问题是如何找出所有的k。

注意到所有的比赛都是两两进行,队伍正好有2^n支,我们可以构造成完全二叉树,所有的队伍都是叶子节点,父节点的权值为胜利的队伍。这样的话,能和a交战的队伍就是父节点和a为兄弟节点的节点。(给二叉树学的和我一样烂的同学的提示,右移操作能找出父节点,异或操作能找出兄弟节点)

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn=150;
double p[maxn][maxn];
double dp[maxn][maxn];
int main()
{
    int n;
    while(cin>>n&&(n+1))
    {
        int m=(1<<n);
        for(int i=0;i<m;i++)
            for(int j=0;j<m;j++)
                scanf("%lf",&p[i][j]);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<m;i++)
            dp[0][i]=1;
        for(int i=1;i<=n;i++)
            for(int j=0;j<m;j++)
                for(int k=0;k<m;k++)
                    if((j>>(i-1)^1)==(k>>(i-1)))
                        dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];

        int ans=0;
        for(int i=0;i<m;i++)
            if(dp[n][i]>dp[n][ans])
                ans=i;
        cout<<ans+1<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值