poj3071之概率DP

Football
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2667 Accepted: 1361

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2
/*分析:假设dp[i][j]表示进行第i次比赛j赢得概率
则主要在于计算第i次比赛可能与j相邻的队伍t并且本次是与t比赛 
然后dp[i][j]+=dp[i-1][j]*dp[i-1][t]*p[j][t]
对于t如何算?
假设队伍id:
0 1 2 3 4 5 6 7
对于第一轮比赛相对上一轮比赛:
0属于第一个赢家,1属于第二个赢家,2属于第三个赢家,3属于第四个赢家... 
第一次比赛后:
0/1 2/3 4/5 6/7
对于第二轮比赛相对上一轮比赛:
0/1属于第一个赢家,2/3属于第二个赢家...
可以发现规律都是:
第奇数个赢家和前一个赢家比赛
第偶数个赢家和后一个赢家比赛
也不难发现规律,对于第j个队伍在第i次比赛
属于第j/(2^(i-1))个赢家//从0开始 
*/
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=(1<<7)+10;
const int N=10+10;
int n;
double p[MAX][MAX],dp[N][MAX];//dp[i][j]表示第i回合j胜利的概率

int main(){
	while(~scanf("%d",&n),n != -1){
		int bit=1<<n;
		for(int i=0;i<bit;++i){
			for(int j=0;j<bit;++j)scanf("%lf",&p[i][j]);
		}
		memset(dp,0,sizeof dp);
		for(int i=0;i<bit;++i)dp[0][i]=1;
		for(int i=1;i<=n;++i){
			for(int j=0;j<bit;++j){
				int t=j>>(i-1);//j经历i-1次属于第t个赢家 
				if(t&1){//j为奇数赢家,本次将与第j-1个赢家比赛 
					for(int k=t*(1<<(i-1))-1;k>=(t-1)*(1<<(i-1));--k){
						dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
					}
				}else{//j为偶数赢家,本次将与第j+1个赢家比赛 
					for(int k=(t+1)*(1<<(i-1));k<(t+2)*(1<<(i-1));++k){
						dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
					}
				}
			}
		}
		int id=0;
		for(int i=0;i<bit;++i){
			if(dp[n][i]>dp[n][id])id=i;
		}
		printf("%d\n",id+1);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值