Aizu - ALDS1_7_d Reconstruction of a Tree 树的重建

Write a program which reads two sequences of nodes obtained by the preorder tree walk and the inorder tree walk on a binary tree respectively, and prints a sequence of the nodes obtained by the postorder tree walk on the binary tree.

Input

In the first line, an integer nn, which is the number of nodes in the binary tree, is given.
In the second line, the sequence of node IDs obtained by the preorder tree walk is given separated by space characters.
In the second line, the sequence of node IDs obtained by the inorder tree walk is given separated by space characters.

Every node has a unique ID from 11 to nn. Note that the root does not always correspond to 11.

Output

Print the sequence of node IDs obtained by the postorder tree walk in a line. Put a single space character between adjacent IDs.

Constraints

  • 1≤n≤401≤n≤40

Sample Input 1

5
1 2 3 4 5
3 2 4 1 5

Sample Output 1

3 4 2 5 1

Sample Input 2

4
1 2 3 4
1 2 3 4

Sample Output 2

4 3 2 1

 给出先序遍历和中序遍历,求后序遍历。

可以通过遍历先序,确定节点的左右子树,然后求解。

代码如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
int n;
int loc=0;
vector <int> pre,in,post;
int finds (int x)
{
    for (int i=0;i<n;i++)
        if(in[i]==x)
           return i;
}
void rec (int l,int r)
{
    if(l>=r)
        return;
    int root=pre[loc++];
    int m=finds(root);
    rec(l,m);
    rec(m+1,r);
    post.push_back(root);
}
void output ()
{
    rec (0,n);
    for (int i=0;i<n;i++)
        printf("%d%c",post[i],i==n-1?'\n':' ');
}
int main()
{
    scanf("%d",&n);
    for (int i=0;i<n;i++)
    {
        int x;
        scanf("%d",&x);
        pre.push_back(x);
    }
    for (int i=0;i<n;i++)
    {
        int x;
        scanf("%d",&x);
        in.push_back(x);
    }
    output();
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值