Reconstruction of a Tree

Write a program which reads two sequences of nodes obtained by the preorder tree walk and the inorder tree walk on a binary tree respectively, and prints a sequence of the nodes obtained by the postorder tree walk on the binary tree.

Input
In the first line, an integer
n
, which is the number of nodes in the binary tree, is given.
In the second line, the sequence of node IDs obtained by the preorder tree walk is given separated by space characters.
In the second line, the sequence of node IDs obtained by the inorder tree walk is given separated by space characters.

Every node has a unique ID from
1
to
n
. Note that the root does not always correspond to
1
.

Output
Print the sequence of node IDs obtained by the postorder tree walk in a line. Put a single space character between adjacent IDs.

Constraints
1

n

40
Sample Input 1
5
1 2 3 4 5
3 2 4 1 5
Sample Output 1
3 4 2 5 1
Sample Input 2
4
1 2 3 4
1 2 3 4
Sample Output 2
4 3 2 1

这是xdu期末数据结构机考的一道题

#include<bits/stdc++.h>
using namespace std;
vector<int>pre,in,post;
int pos,n; 
void res(int l,int r){
	if(l>=r)return ;
	int root =pre[pos++];
	int m=distance(in.begin(),find(in.begin(),in.end(),root));
	res(l,m);
	res(m+1,r);
	post.push_back(root);
}
int main(){
	scanf("%d",&n);int k;
	for(int i=0;i<n;i++){
		scanf("%d",&k);pre.push_back(k);
	}
	for(int i=0;i<n;i++){
		scanf("%d",&k);in.push_back(k);
  }
  res(0,n); 
  for(int i=0;i<n;i++){
 		if(i==0)printf("%d",post[i]);
 		else printf(" %d",post[i]);
  } printf("\n");
  
}```

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值