PAT (Advanced Level) Practice 1146 Topological Order (25 分) 拓扑排序

6 篇文章 0 订阅

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
const int maxn=1005;
int n,m,q;
int in[maxn],out[maxn];
int tin[maxn],re[maxn];
vector<int> ve[maxn],no;
void init()
{
    memset (in,0,sizeof(in));
}
void tinit()
{
    for (int i=1;i<=n;i++)
    {
        tin[i]=in[i];
    }
}
int main()
{
    init();
    scanf("%d%d",&n,&m);
    while (m--)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        ve[x].push_back(y);
        in[y]++;
    }
    scanf("%d",&q);
    for (int k=0;k<q;k++)
    {
        tinit();
        for (int i=0;i<n;i++)
            scanf("%d",&re[i]);
        for (int i=0;i<n;i++)
        {
            if(tin[re[i]])
            {
                no.push_back(k);
                break;
            }
            else
            {
                for (int j=0;j<ve[re[i]].size();j++)
                {
                    tin[ve[re[i]][j]]--;
                }
            }
        }
    }
    int Size=no.size();
        for (int i=0;i<Size;i++)
            printf("%d%c",no[i],i==Size-1?'\n':' ');
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
利用深度优先搜索实现拓扑排序的步骤如下: 1. 构建图的邻接表表示。 2. 统计每个节点的入度。 3. 从入度为0的节点开始,进行深度优先搜索,并将已经访问过的节点加入结果列表中。 4. 搜索完成后,将结果列表反转即可得到拓扑排序的结果。 以下是利用深度优先搜索实现拓扑排序的Python代码示例: ```python from collections import defaultdict class Graph: def __init__(self, num_vertices): self.graph = defaultdict(list) self.num_vertices = num_vertices def add_edge(self, u, v): self.graph[u].append(v) def topological_sort_util(self, v, visited, stack): visited[v] = True for i in self.graph[v]: if not visited[i]: self.topological_sort_util(i, visited, stack) stack.append(v) def topological_sort(self): visited = [False] * self.num_vertices stack = [] for i in range(self.num_vertices): if not visited[i]: self.topological_sort_util(i, visited, stack) return stack[::-1] # 示例 g = Graph(6) g.add_edge(5, 2) g.add_edge(5, 0) g.add_edge(4, 0) g.add_edge(4, 1) g.add_edge(2, 3) g.add_edge(3, 1) print("拓扑排序结果:", g.topological_sort()) ``` 逆拓扑排序拓扑排序类似,只不过是将图中的边反向,然后再进行拓扑排序。以下是逆拓扑排序的Python代码示例: ```python from collections import defaultdict class Graph: def __init__(self, num_vertices): self.graph = defaultdict(list) self.num_vertices = num_vertices def add_edge(self, u, v): self.graph[v].append(u) def topological_sort_util(self, v, visited, stack): visited[v] = True for i in self.graph[v]: if not visited[i]: self.topological_sort_util(i, visited, stack) stack.append(v) def topological_sort(self): visited = [False] * self.num_vertices stack = [] for i in range(self.num_vertices): if not visited[i]: self.topological_sort_util(i, visited, stack) return stack[::-1] # 示例 g = Graph(6) g.add_edge(2, 5) g.add_edge(0, 5) g.add_edge(0, 4) g.add_edge(1, 4) g.add_edge(3, 2) g.add_edge(1, 3) print("逆拓扑排序结果:", g.topological_sort()) ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值