PAT (Advanced Level) Practice 1146 Topological Order

题目

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:
3 4

题意理解

输入
N——顶点总数
M——边总数
M行 起始点和终点序列
K——需判断是否合法的序列总数
K行序列
输出 拓扑排序不合法序列的索引编号,从0开始

解题思路

用邻接表v存储这个有向图,并将每个节点的入度保存在in数组中。对每一个要判断是否是拓扑序列的结点遍历,如果当前结点的入度不为0则表示不是拓扑序列,每次选中某个点后要将它所指向的所有结点的入度-1,最后根据是否出现过入度不为0的点决定是否要输出当前的编号i
flag是用来判断之前是否输出过现在是否要输出空格
judge是用来判断是否是拓扑序列的,judge=0为不合法
注意如果序列合法,则进入下一序列判断,使用continue,如果不合法则执行下面语句,根据flag决定是否输出空格;注意每次序列判断前需要将入度矩阵恢复成原有状态,需要重新定义一个数组拷贝入度矩阵

解题代码

#include <iostream>
#include <vector>
using namespace std;
int main() {
	int n, m, a, b, k, flag = 0;
	int in[1010] = { 0 };
	vector<int> v[1010];
	cin >> n >> m;
	for (int i = 0; i < m; i++) {
		cin >> a >> b;
		v[a].push_back(b);
		in[b]++;
	}
	cin >> k;
	for (int i = 0; i < k; i++) {
		int judge = 1;
		vector<int> tin(in, in + n + 1);//将in数组中有效值部分复制到tin数组中从0开始,要存1到n个值,因此数组大小为n+1,每次循环都需要重新赋值因为tin数组值会改变
		for (int j = 0; j < n; j++) {
			cin >> a;
			if (tin[a] != 0) judge = 0;
			for (int i = 0; i < v[a].size(); i++) {
				tin[v[a][i]]--;
			}
		}
		if (judge == 1) continue;
		if (flag == 1) {
			cout << " "<<i;
		}
		else {
			cout << i;
		}
		flag = 1;
	}
	return 0;
}

*也可以通过定义一个拓扑排序函数判断,用队列思想解决,比较复杂不推荐

const int MAXV = 1010;
vector<int> G[MAXV];
int N, M;
int tosort(int A[], int n,int ind[]) {
	queue<int> q;
	for (int i = 0; i < n; i++) {
		q.push(A[i]);
	}
	while (!q.empty()) {
		int u = q.front();
		q.pop();
		for (int i = 0; i < G[u].size(); i++) {
			int v = G[u][i];
			ind[v]--;
		}
		if (!q.empty()) {		
		int x = q.front();
		if (ind[x] != 0) {
			return -1;
		}
		}
	}
	return 1;
}
int main() {
	cin >> N >> M;
	int inD[MAXV] = { 0 };
	int copyinD[MAXV] = { 0 };
	for (int i = 0; i < M; i++) {
		int a, b;
		cin >> a >> b;
		G[a].push_back(b);
		inD[b]++;
		copyinD[b]++;
	}
	int K;
	cin >> K;
	int order[1010] = {0};
	int ans[1010] = { 0 };
	int num = 0;
	for (int i = 0; i < K; i++) {
		for (int j = 0; j < N; j++) {
			cin >> order[j];
		}
		for (int i = 1; i <= N; i++) {
			inD[i] = copyinD[i];
		}
		if (tosort(order, N, inD) == -1) {
			ans[num++] = i;
		}
	}
		for (int i = 0; i < num; i++) {
			cout << ans[i];
			if (i != num - 1) {
				cout << " ";
			}
		}

	     return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值