Hdu 1792 A New Change Problem 结论

53 篇文章 0 订阅

 

Problem Description

Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.

 

 

Input

The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.

 

 

Output

For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.

 

 

Sample Input

 

2 3

3 4

 

 

Sample Output

 

1 1

5 3

题意:
求两个互质数的最大不能组成的数和不能组成的数的个数....

网上找的公式.....

最大不能组成的数为a*b-a-b;

不能组成的数为(a-1)*(b-1)/2;

代码如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int a,b;
int main()
{
    while (scanf("%d%d",&a,&b)!=EOF)
    {
        printf("%d %d\n",a*b-a-b,(a-1)*(b-1)/2);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值