A New Change Problem(结论题(待证明))

A New Change Problem

 Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay. 

Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.
Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.
Sample Input

2 3
3 4

Sample Output

1 1
5 3
题意:

给定A和B,A和B互质,求最大不能组合数,和不能组合数的个数

分析:

有这么一个结论:

给定A和B,A和B互质

最大不能组合数为 A×BAB A × B − A − B

不能组合数的个数为 (A1)(B1)2 ( A − 1 ) ( B − 1 ) 2

关于这个结论的证明我太菜还没看懂。。网上证明的博客实际上都是一篇博客,都互相复制的,我目前确实没能力写出证明非常抱歉。。。

如果有大佬写出了自己的证明麻烦各位大佬在下面留言您的博客地址感激不尽

code:

#include <bits/stdc++.h>
using namespace std;
int main(){
    int A,B;
    while(~scanf("%d%d",&A,&B)){
        printf("%d %d\n",A*B-A-B,(A-1)*(B-1)/2);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值