Hdu 3575 Hello Kiki 中国剩余定理模板

53 篇文章 0 订阅

Problem Description

One day I was shopping in the supermarket. There was a cashier counting coins seriously when a little kid running and singing "门前大桥下游过一群鸭,快来快来 数一数,二四六七八". And then the cashier put the counted coins back morosely and count again...
Hello Kiki is such a lovely girl that she loves doing counting in a different way. For example, when she is counting X coins, she count them N times. Each time she divide the coins into several same sized groups and write down the group size Mi and the number of the remaining coins Ai on her note.
One day Kiki's father found her note and he wanted to know how much coins Kiki was counting.

 

 

Input

The first line is T indicating the number of test cases.
Each case contains N on the first line, Mi(1 <= i <= N) on the second line, and corresponding Ai(1 <= i <= N) on the third line.
All numbers in the input and output are integers.
1 <= T <= 100, 1 <= N <= 6, 1 <= Mi <= 50, 0 <= Ai < Mi

 

 

Output

For each case output the least positive integer X which Kiki was counting in the sample output format. If there is no solution then output -1.

 

 

Sample Input

 

2 2

14 57

5 56

5

19 54 40 24 80

11 2 36 20 76

 

 

Sample Output

 

Case 1: 341

Case 2: 5996

套用中国剩余定理模板即可求解....

注意此题有特判, 当余数为0时, 输出最小公倍数.....

代码如下:
 

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=55;
int t;
typedef __int64 ll;
ll m[maxn],a[maxn];
int k;
ll Extend (ll A,ll B,ll& X,ll& Y)
{
    if(B==0)
    {
        X=1; Y=0;
        return A;
    }
    else
    {
        ll ans,temp;
        ans=Extend (B,A%B,X,Y);
        temp=X;
        X=Y;
        Y=temp-A/B*Y;
        return ans;
    }
}
ll solve ()
{
    ll x,y,d,t,c;
    for (int i=1;i<k;i++)
    {
         c=a[i]-a[i-1];
         d=Extend (m[i-1],m[i],x,y);
         if(c%d) return -1;
         x=c/d*x;
         t=m[i]/d;
         x=(x%t+t)%t;
         a[i]=m[i-1]*x+a[i-1];
         m[i]=m[i]/d*m[i-1];
    }
    if(a[k-1]==0)
        a[k-1]=m[k-1];
    return a[k-1];
}
int main()
{
    scanf("%d",&t);
    for (int j=1;j<=t;j++)
    {
        scanf("%d",&k);
        for (int i=0;i<k;i++)
            scanf("%I64d",&m[i]);
        for (int i=0;i<k;i++)
            scanf("%I64d",&a[i]);
        ll ans=solve();
        printf("Case %d: %I64d\n",j,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值