POJ - 3984 迷宫问题 记忆化搜索

19 篇文章 0 订阅

Description

定义一个二维数组:

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

思路:

通过一个数组来实现对经过路径的记录,便于结果的输出。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
using namespace std;
int dri[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
struct node
{
    int x,y;
    int pre;
    int id;
}b[100005];
int a[10][10];
int vis[10][10];
int num=0;
int bfs ()
{
    queue<node>q;
    node now,next;
    now.x=0,now.y=0;
    now.pre=-1; now.id=0;
    b[num++]=now;
    q.push(now);
    vis[0][0]=1;
    while (!q.empty())
    {
        now=q.front();q.pop();
        if(now.x==4&&now.y==4)
        {
            return now.id;
        }
        for (int i=0;i<4;i++)
        {
            next.x=now.x+dri[i][0];
            next.y=now.y+dri[i][1];
            next.pre=now.id;
            if(next.x>=0&&next.x<5&&next.y>=0&&next.y<5&&vis[next.x][next.y]==0&&a[next.x][next.y]==0)
            {
                vis[next.x][next.y]=1;
                next.id=num;
                b[num++]=next;
                q.push(next);
            }
        }
    }
    return -1;
}
int main()
{
    for (int i=0;i<5;i++)
        for (int j=0;j<5;j++)
            scanf("%d",&a[i][j]);
    memset (vis,0,sizeof(vis));
    int no=bfs();
    stack<node>s;
    while (no!=-1)
    {
        s.push(b[no]);
        no=b[no].pre;
    }
    while (!s.empty())
    {
        node t=s.top(); s.pop();
        printf("(%d, %d)\n",t.x,t.y);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值