POJ 2010 Moo University - Financial Aid 贪心

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short.

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000.

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000).

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible.

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it.

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves.
 

Input

* Line 1: Three space-separated integers N, C, and F

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1.

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30

Sample Output

35

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70.

题意:

从c个学生里面选出n个学生,让n个学生中的中位数成绩最高。

思路:

本来的思路就是将成绩按从大到小的顺序排序, 然后将资金按从小到大的顺序排序, 然后对每个成绩进行遍历,从符合条件的资金数组挑人, 我 原本以为这个思路很正确, 然后写了, wa了。 。。 。

后来从网上借鉴, 学了一手二分查找。

( 1)先是对s1成绩按从小到大的顺序排序。

( 2)然后对s2按资金从小到大的顺序排序。

(3)然后对s1进行二分, 然后每次遍历s2一遍,对满足条件的分别计入left跟right中。

1.如果left<n/2并且right<n/2的话, 表明没有符合条件的答案。

2.如果left<n/2, 说明mid元素太小了, 需要往右移动, 即la= mid;

3.如果right<n/2, 说明mid元素太大了, 需要往左移动, 即lb= mid;

4.如果符合条件, 那么继续贪心, 继续往右找。 即la= mid。

还有,这题用qsort会超时,切记用sort

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
const int maxn=100005;
int n,c,f;
struct stu
{
    int score;
    int needs;
    int rank_c;
};
stu s1[maxn],s2[maxn];
//按照资金从小到大排序
bool compare ( stu a,stu b)
{
    return a.needs<b.needs;
}
//按照分数从大到小排序
bool compare1 (stu a,stu b)
{
    return a.score<b.score;
}
int main()
{
    while (scanf("%d%d%d",&n,&c,&f)!=EOF)
    {
        for (int i=0;i<c;i++)
     {
        scanf("%d%d",&s1[i].score,&s1[i].needs);
     }
    //按照成绩从小到大的顺序排序;
    sort (s1,s1+c,compare1);
    for (int i=0;i<c;i++)
        {
            s1[i].rank_c=i;
            s2[i]=s1[i];
        }
    //按资金从小到大排列
    sort (s2,s2+c,compare);
    int la=0,lb=c,re=-1;
    //二分查找;
    while (lb-la>1)
     {
        //取中间值
        int mid=(la+lb)/2;
        int left=0,right=0,total=s1[mid].needs;
        //筛选
        for (int i=0;i<c;i++)
        {
            if((s2[i].rank_c<mid)&&(total+s2[i].needs<=f)&&(left<n/2))
            {
                left++;
                total+=s2[i].needs;
            }
            if((s2[i].rank_c>mid)&&(total+s2[i].needs<=f)&&(right<n/2))
            {
                right++;
                total+=s2[i].needs;
            }
        }
        //判断
        if((left<n/2)&&(right<n/2))
        {
            re=-1;
            break;
        }
        else if(left<n/2)
        {
            la=mid;
        }
        else if(right<n/2)
        {
            lb=mid;
        }
        else
        {
            re=s1[mid].score;
            la=mid;
        }
     }
    printf("%d\n",re);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值