1588-圆的面积-JAVA

圆的面积

Time Limit: 1000 ms Memory Limit: 32768 KiB


Problem Description

    Give you the radius of a circle,caculate its area,PI=3.141592653。


Input

The first line of the input is a positive integer N,then follows N lines,each line is a real number represent the radius of the circle. 

Output

Output contains N lines,for each line of the input you should output one line, Case K: S,and K(count from 1)represents the number of the circle and S is the area.Keep two digits after the decimal point.


Sample Input

3
1
2
3

Sample Output

Case 1: 3.14
Case 2: 12.57
Case 3: 28.27

Hint


Source

import java.text.*;
import java.util.*;

public class Main {

	public final static double PI = 3.141592653;

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		DecimalFormat decimalFormat = new DecimalFormat("0.00");
		int n = scanner.nextInt();
		for (int i = 1; i <= n; i++) {
			int r = scanner.nextInt();
			System.out.println("Case " + i + ": " + decimalFormat.format(PI * r * r));
		}
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值