poj 3278 Catch That Cow(bfs入门级别,经典模板)

C - Catch That Cow

POJ - 3278

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题干很好懂,如果没懂看一下给的提示也懂了
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
using namespace std;
bool vis[100010];
int step[100010];
int k, n;
int bfs(int n, int k)
{
    memset(vis, 0, sizeof(vis));
    memset(step, 0, sizeof(step));
    int head, next;
    queue<int>q;
    while(!q.empty())q.pop();
    q.push(n);
    step[n] = 0;
    vis[n] = 1;
    while(!q.empty())
    {
        head = q.front();
        q.pop();
        for(int i = 0; i < 3; i ++)
        {
            if(i == 0)next = head - 1;
            else if (i == 1)next = head + 1;
            else next = head * 2;
            if(next < 0||next >= 100010)continue;
            if(!vis[next])
            {
                q.push(next);
                step[next] = step[head] + 1;
                vis[next] = 1;
            }
            if(next == k) return step[next];
        }
    }
    return 0;
}
int main()
{
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n >= k)printf("%d\n", n - k);
        else printf("%d\n",bfs(n, k));
    }
    return 0;
}
其实这道题做完之后感觉之前的bfs都白做了,因为这完全是用bfs实现了穷举,非常惭愧第一次见识到bfs的厉害,这个模板非常经典,没事一定多回来看看
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值