POJ 1847 Tram(简单最短路之Floyd)

N - Tram

POJ - 1847

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input
The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.
Output
The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".
Sample Input
3 2 1
2 2 3
2 3 1
2 1 2
Sample Output
0

这题用最短路的几种方法应该都能做出来,Floyd比较简单所以用了这个,刚学最短路先练练手呗

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
//火车从一点开到另一点,n路口都有好几个方向,默认指向第一个方向,
//所以如果要选择别的方向的话得 进行一次切换操作 ,给定一个起点一个终点 
//问最少进行几次 切换操作 能够走完,如果无法到达,输出“-1”

int mapp[110][110];
int n;
void init()
{
    for(int i = 1; i <= n; i ++)
        for(int j = 1; j <= n; j ++)
        if(i == j)mapp[i][j] = 0;
        else mapp[i][j] = inf;
}
int main()
{
    int a, b;
    int k;
    int temp;
    while(scanf("%d%d%d",&n,&a,&b)!=EOF)
    {
        init();
        for(int o = 1; o <= n; o ++)
        {
            scanf("%d",&k);
            int temp1 = 0;//表示距离,初始为0,后来为1
            for(int i = 0; i < k; i ++)
            {
                scanf("%d",&temp);
                mapp[o][temp] = temp1;
                temp1 = 1;
            }
        }
        for(int k = 1; k <= n; k ++)//Floyd核心代码
            for(int i = 1; i <= n; i ++)
                for(int j = 1; j <= n; j ++)
        {
            if(mapp[i][j] > mapp[i][k] + mapp[k][j])
                mapp[i][j] = mapp[i][k] + mapp[k][j];
        }
//        if(a > b)
//        {
//            temp = a;
//            a = b;
//            b = temp;
//        }
        if(mapp[a][b]<inf)
        printf("%d\n",mapp[a][b]);
        else printf("-1\n");//很容易忘记如果没有结果的情况
    }
    return 0;
}
没事回过头来更新这道题的最短路其他算法解?

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值