poj 2406 Power Strings

2 篇文章 0 订阅

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

判断最小循环节,如果有循环节的话,用长度除以循环节长度就为结果

#include <iostream>
#include<string.h>
#include<algorithm>
#include<cstdio>
#define ll long long
const int mod=1e9+7;
using namespace std;
int next[1000005];
char a[1000005];
int k,j,len;
int main()
{
    while(gets(a))
    {
        if(strcmp(a,".")==0)break;
        memset(next,0,sizeof(next));
         len=strlen(a);
         j=-1;
         k=0;
         next[0]=-1;
        while(k<len)
        {
            if(j==-1||a[j]==a[k])
            {
               next[++k] = ++j;
            }
            else
            {
                j=next[j];
            }
        }
        int ans=1;
        if(len%(len-next[len])==0)
            ans=len/(len-next[len]);
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值