PAT (Advanced Level)-1148 Werewolf - Simple Version

1148 Werewolf - Simple Version(20 分)

PAT (Basic Level)-1089 狼人杀-简单版(20 分)

Werewolf(狼人杀) is a game in which the players are partitioned into two parties: the werewolves and the human beings. Suppose that in a game,

  • player #1 said: "Player #2 is a werewolf.";
  • player #2 said: "Player #3 is a human.";
  • player #3 said: "Player #4 is a werewolf.";
  • player #4 said: "Player #5 is a human."; and
  • player #5 said: "Player #4 is a human.".

Given that there were 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. Can you point out the werewolves?

Now you are asked to solve a harder version of this problem: given that there were N players, with 2 werewolves among them, at least one but not all the werewolves were lying, and there were exactly 2 liars. You are supposed to point out the werewolves.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (5≤N≤100). Then N lines follow and the i-th line gives the statement of the i-th player (1≤i≤N), which is represented by the index of the player with a positive sign for a human and a negative sign for a werewolf.

Output Specification:

If a solution exists, print in a line in ascending order the indices of the two werewolves. The numbers must be separated by exactly one space with no extra spaces at the beginning or the end of the line. If there are more than one solution, you must output the smallest solution sequence -- that is, for two sequences A=a[1],...,a[M] and B=b[1],...,b[M], if there exists 0≤k<Msuch that a[i]=b[i] (i≤k) and a[k+1]<b[k+1], then A is said to be smaller than B. In case there is no solution, simply print No Solution.

Sample Input 1:

5
-2
+3
-4
+5
+4

Sample Output 1:

1 4

Sample Input 2:

6
+6
+3
+1
-5
-2
+4

Sample Output 2 (the solution is not unique):

1 5

Sample Input 3:

5
-2
-3
-4
-5
-1

Sample Output 3:

No Solution

考试遇到这题 卡了1个多小时 没想出来最后只过了样例 思路比较乱 乍一看似乎是需要dfs来做 摆在第一题 心想不可能这么复杂

实际上 此题是顶级改编 困难版本是狼人数和撒谎人数都不确定 需要dfs+剪枝条件

简单版本若能想到顺序从小到大枚举出两个狼人,两个狼人一旦确定 撒谎的人也就可以确定了(这个想到就简单了)然后 就判断条件:撒谎人数==2? 2人是否为一狼一人就可以了 

考完很多同学表示死在第一题 心态就好多了 (逃……)

dfs回溯+条件剪枝(参考了大神的代码)版本:

#include <iostream>
#include <vector>
using namespace std;

int n,a[102],wolf[102];
vector<int>say[102],buf,res;
int lie,lie2,wlie;
void dfs(int idx)
{
	if(lie>2)return;
	if(buf.size()==2)
	{
		lie2=wlie=0;
		for(int i=1;i<=n;i++)
		{
			if((a[i]>0&&wolf[a[i]]==1)||(a[i]<0&&wolf[-a[i]]==0))
			{
				lie2++;
				if(wolf[i])wlie++;
			}
		}
		if(wlie==1&&lie2==2)
		{
			res.push_back(buf[0]);
			res.push_back(buf[1]);			
		}
		return;
	}
	for(int k=idx;k<=n;k++)
	{
		buf.push_back(k);
		wolf[k]=1;
		for(auto &x:say[k])
		{
			lie+=x>0?1:0;
		}
		dfs(k+1);
		buf.pop_back();
		wolf[k]=0;
		for(auto &x:say[k])
		{
			lie+=x>0?-1:0;
		}
	}
}
int main()
{
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		if(a[i]<0)say[-a[i]].push_back(-i);
		else say[a[i]].push_back(i);
	}
	dfs(1);
	if(res.size()==0)printf("No Solution\n");
	else printf("%d %d\n",res[0],res[1]);
	
}

常规暴力枚举版本:

#include <iostream>
#include <vector>
using namespace std;
int main()
{
	int n;
	cin>>n;
	vector<int>v(n+1);
	for(int i=1;i<=n;i++)scanf("%d",&v[i]);
	for(int i=1;i<=n;i++)
	{
		for(int j=i+1;j<=n;j++)
		{
			vector<int>lie,wolf(n+1,0);
			wolf[i]=wolf[j]=1;
			for(int k=1;k<=n;k++)
			{
				if((v[k]>0&&wolf[v[k]]==1)||(v[k]<0&&wolf[-v[k]]==0))lie.push_back(k);
			}
			if(lie.size()==2&&wolf[lie[0]]+wolf[lie[1]]==1)
			{
				printf("%d %d\n",i,j);
				return 0;
			}			
		}
	}
	printf("No Solution\n");
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值