PAT (Advanced Level)-1107 Social Clusters(并查集)

1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

社交圈 是由人组成且圈中的人彼此有爱好相同

模拟样例:爱好分为1 3 4 5 6 7 8 10 这几种

一共8个人(从0开始记) 共同爱好4下 有1 3 5 7这四个人 共同爱好3下 有 024 这三个人 虽然6与2 有共同爱好5 但6无法归入024的圈中 因此 共 3个圈 

用并查集 新开一个数组为爱好 初始化为0  若i人爱好t hobby[t]=i 此时这个爱好t 由i做老大 后来有人再喜欢这个爱好自动归顺i人

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
vector<int> clus,f;
int hobby[1001];
int getf(int v)
{
	return f[v]==v?v:f[v]=getf(f[v]);
}
void merge(int u,int v)
{
	int t1,t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
	{
		f[t1]=t2;
	}
}
int main() 
{
	int n;
	scanf("%d",&n);
	clus.resize(n+1);
	f.resize(n+1);	
	for(int i=1;i<=1001;i++)f[i]=i;
	for(int i=1;i<=n;i++)
	{
		int k;
		scanf("%d:",&k);
		for(int j=0;j<k;j++)
		{
			int t;
			scanf("%d",&t);
			if(hobby[t]==0)
				hobby[t]=i;
			merge(i,getf(hobby[t]));
		}
	}
	int cnt=0;
	for(int i=1;i<=n;i++)
	{
		clus[getf(i)]++;
	}
	for(int i=1;i<=n;i++)
	{
		if(clus[i])cnt++;
	}
	sort(clus.begin(),clus.end(),greater<int>());
	printf("%d\n",cnt);
	for(int i=0;i<cnt;i++)
	{
		printf("%d",clus[i]);
		if(i!=cnt-1)printf(" ");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值