PAT 1004 成绩排名 (20 分)

17 篇文章 0 订阅

1004 成绩排名 (20 分)

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
  ... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

 

输出样例:

Mike CS991301
Joe Math990112

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

#include<iostream>
#include<string>
using namespace std;

int main()
{
    int n;
    string name[10000];
    string id[10000];
    int score[10000];
    int peak_no;
    int bottom_no;
    int peak_score=0;
    int bottom_score=101;
    cin>>n;

    for(int i=0;i<n;i++)
    {
        cin>>name[i];
        cin>>id[i];
        cin>>score[i];
        if(peak_score<=score[i])
        {
            peak_score=score[i];
            peak_no=i;
        }
        if(bottom_score>=score[i])
        {
            bottom_score=score[i];
            bottom_no=i;
        }
    }
        cout<<name[peak_no]<<" "<<id[peak_no]<<endl;
        cout<<name[bottom_no]<<" "<<id[bottom_no]<<endl;


}

一开始我的数组设置的过小,会出现一个段错误,段错误的意思是代码可能会有数组越界堆栈溢出的问题。

测试点一二没问题说明代码功能都实现了,但是在测试点三中提示段错误很可能是我的数组不够大,测试点输进去就越界了,扩大数组就可以。

不同于CCFCSP认证中的题目,PAT不会给出测试数据的范围,所以我应开始尝试使用动态数组

#include<iostream>
#include<string>
using namespace std;

int main()
{
    int n;
    cin>>n;
    string *name=new string[n];
    string *id=new string[n];
    int *score=new int[n];
    int peak_no;
    int bottom_no;
    int peak_score=0;
    int bottom_score=101;

    for(int i=0;i<n;i++)
    {
        cin>>name[i];
        cin>>id[i];
        cin>>score[i];
        if(peak_score<=score[i])
        {
            peak_score=score[i];
            peak_no=i;
        }
        if(bottom_score>=score[i])
        {
            bottom_score=score[i];
            bottom_no=i;
        }
    }
        cout<<name[peak_no]<<" "<<id[peak_no]<<endl;
        cout<<name[bottom_no]<<" "<<id[bottom_no]<<endl;
        delete []name;
        delete []id;
        delete []score;
}

 

动态数组的建立:

    string *name=new string[n];
    string *id=new string[n];
    int *score=new int[n];

释放动态数组的空间:

        delete []name;
        delete []id;
        delete []score;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值