NYOJ:Binary String Matching(kmp)

http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=5

描述

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入

3
11
1001110110
101
110010010010001
1010
110100010101011 

样例输出

3
0
3 

求出b字符串在a支付串中出现了几次。kmp算法

#include<stdio.h>
#include<string.h>
#define N 1020
int next[N],len1,len2;
char a[N],b[N];
void get_next()
{
	int i=0,j=-1;
	next[0]=-1;
	while(i<len2)
	{
		if(b[i]==b[j]||j==-1)
		{
			i++;
			j++;
			next[i]=j;
		}
		else
			j=next[j];
	}
}
int kmp()
{
	int ans=0;
	get_next();
	int i=0,j=0;
	while(i<len1)
	{
		if(a[i]==b[j]||j==-1)
		{
			i++;
			j++;
		}
		else
			j=next[j];
		if(j>=len2)
		{
			ans++;
			j=next[j];
		}
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%s",b,a);
		memset(next,0,sizeof(next));
		len1=strlen(a);
		len2=strlen(b);
		printf("%d\n",kmp());
	}
	return 0;	
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值