Binary String Matching

                                                              时间限制:3000 ms  |  内存限制:65535 KB

                                                                                          难度:3

描述

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入

3
11
1001110110
101
110010010010001
1010
110100010101011 

样例输出

3
0
3 

代码:

#include<stdio.h>
#include<string.h>
int main(){
	int T,i,j,k,len1,len2,count;
	char s[15],t[1010],ch[15];
	scanf("%d",&T);
	while(T--){
		k=count=0;
		memset(ch,0,sizeof(ch));
		scanf("%s %s",s,t);
		len1=strlen(s);
		len2=strlen(t);
		j=0;
		for(i=0;i<len2;i++){
			ch[k++]=t[i];
			ch[k]='\0';
			if(k==len1){
				if(strcmp(ch,s)==0)
					count++;
				i=j;
				j++;
				k=0;
			}
		}
		printf("%d\n",count);	
	}
	return 0;
}
#include<iostream> 
#include<string> 
using namespace std; 
int main() { 
    int N;
    cin>>N;
    while(N--) {
        string s,a,b;
        cin>>a>>b;
        int at =0,i=0,len;
        while((i=b.find(a,i))!=(string::npos)) { 
            at++;
            i++; 
        } 
        cout<<at<<endl; 
    } 
}
注解:
i=b.find(a,i)   //在字符串b中查找字符串a从b字符中第i个元素开始查找,返回为int型的数值重新赋值给i,string::npos是标准库的string容器属性。返回字符存放位置。 这个东西是一个容器,它将字符串分成一个一个来存储。
while((i=b.find(a,i))!=(string::npos)) { 
   at++;   //计算器
   i++;     
  }  //对b中字符串逐次与a比较直到结束

 

 

 

自己写的错误的代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	int N,len1,len2,k,count,j;
	string s;
	string str;
	string copy;
	scanf("%d",&N);
	
		while(N--)
		{   k=0,count=0,j=0;
			scanf("%s",&s);
			getchar();
			scanf("%s",&str);
			 len1=s.length()    ;	//s是一个string类型的变量,s.length返回s的长度
			 len2=str.length()  ;//s是一个string类型的变量,s.length返回str的长度
			for(int i=0;i<len2;i++)
			{
				copy[k++]=str[i];
				copy[k]='\0';
				if(k==len1){
					if( strcmp(copy.c_str() ,s.c_str() )==0)//通过string的成员函数c_str()把string转换为const char *
					count++;
					i=j;
					j++;
					k=0;
				}
			}
			printf("%d\n",count);
		}
	
	return 0;
	
}

//s.length()的C++代码是什么意思?
s.length()的意思是计算字符串s的长度,其返回值是一个整数,
{string s = "abc"; //注意,s的长度为3,而s的字符数为4(包括结束符'\0')int i=s.length(); //计算长度并把值赋给icout<<"s的字符数为:"<<i<<endl;return 0;}
<script Language="JavaScript">function maxlength(str,minl,maxl) {if(str.length <= maxl && str.length >= minl){return true;}else{return false;}}
length表示的是数组的长度,而String类提供的length方法也是取得字符串的长度的。不过只有数组才可以使用数组名称.length,至于字符串没有。就是字符串没有s.length这种写法。 s.length()是指调用String类的方法输出字符串的长度。
 

//什么是std::string...?怎么用?
这是C++的写法:std::string
std是命名空间,std::string可以定义一个类型为srting的变量
如果你使用了using namespace std; std::string可以写成string,比如:
string str;

//C++中strcmp() 的参数可以是string类型吗?
函数原型:int strcmp(const char *s1,const char *s2);
参数是const char*,或者char*
不能是string类型,但是可以通过string的成员函数c_str()把string转换为const char *

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值