百练(POJ) 2253:Frogger(Dijkstra变形)

http://bailian.openjudge.cn/practice/2253/

描述

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

输入

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

输出

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

样例输入

2
0 0
3 4

3
17 4
19 4
18 5

0

样例输出

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意分析:

一只青蛙要到另一只青蛙那去,池塘中有n个石头,因为距离太远不能一次跳过去,可以先跳到其他石头上,求青蛙最少要满足一次能跳多少米。

解题思路:

在每次松弛的时候如果两条边都小于要松弛的边,把边更新成两条边中较大的一个。

注意POJ上要以%.3f输出。。。

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
#define N 220
using namespace std;
 
struct point{
	int x;
	int y;
}a[N];
int n, i, j, u, v, inf=0x9f9f9f;
double e[N][N], dis[N], mini;
bool book[N];
int main()
{
	int t=0;
	while(scanf("%d", &n), n!=0)
	{
		for(i=1; i<=n; i++)
			scanf("%d%d", &a[i].x, &a[i].y);
		for(i=1; i<=n; i++)
			for(j=1; j<=n; j++)
			{
				if(i==j)
					e[i][j]=0;
				else
					e[i][j]=sqrt(1.0 * ((a[i].x-a[j].x) * (a[i].x-a[j].x) + (a[i].y-a[j].y) * (a[i].y-a[j].y)));
			}		
		dis[1]=0;
		for(i=2; i<=n; i++)
			dis[i] = e[1][i];
		memset(book, false, sizeof(book));
		book[1]=true; 
		for(i=1; i<n; i++)
		{
			mini=inf;
			for(j=1; j<=n; j++)
			{
				if(dis[j]<mini && book[j]==false)
				{
					u=j;
					mini=dis[j];
				}
			}
			book[u]=true;
			for(v=1; v<=n; v++)
			{
				if(dis[v]>dis[u] && dis[v]>e[u][v])
					dis[v] = max(dis[u], e[u][v]);
			}
		}
		printf("Scenario #%d\nFrog Distance = %.3f\n\n", ++t, dis[2]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值