POJ 1860:Currency Exchange(Bellman-Ford)

http://poj.org/problem?id=1860

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题意分析:

有m个地点可以兑换货币,每个地点只能兑换两种货币,兑换货币需要佣金,现在有一种S币,问有没有可能一种兑换方式可以使前无限增加,即最后的钱兑换成S币会比最初多。

解题思路:

和最短路是一样的思想,判断最长的路能不能一直增加,最开始我输出的判断条件是dis[s]>v,就是判断S币在n轮中能不能增加,最后发现其实这样想是错的,因为其他币兑换S币的兑率可能很低,所以只要判断n轮后其他币还能不能增加,因为是无限增加,所以最后肯定可以兑换S币。

#include <stdio.h>
#include <string.h>
#define N 220
struct date{
	int u, v;
	double h,y;
}a[N];
double dis[N];
int main()
{
	int n, m, i, j, s, temp, inf=99999999;
	double v;
	while(scanf("%d%d%d%lf", &n, &m, &s, &v)!=EOF)
	{
		for(i=1; i<=m; i++)
		{
			scanf("%d%d%lf%lf%lf%lf", &a[i].u, &a[i].v, &a[i].h, &a[i].y, &a[i+m].h, &a[i+m].y);
			a[i+m].u=a[i].v;
			a[i+m].v=a[i].u;
		}
		memset(dis, 0, sizeof(dis));
		dis[s]=v;
		for(i=1; i<n; i++)
		{
			temp=0;
			for(j=1; j<=2*m+1; j++)
			{
				if(dis[a[j].v]<(dis[a[j].u]-a[j].y)*a[j].h)
				{
					dis[a[j].v]=(dis[a[j].u]-a[j].y)*a[j].h;
					temp=1;
				}
			}
			if(temp==0)
				break;
		}
		temp=0;
		for(j=1; j<=2*m+1; j++)
		{
			if(dis[a[j].v]<(dis[a[j].u]-a[j].y)*a[j].h)
			{
				dis[a[j].v]=(dis[a[j].u]-a[j].y)*a[j].h;
				temp=1;
				break;
			}
		}
		if(temp==1)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值