FZU Problem 2150: Fire Game (BFS)

http://acm.fzu.edu.cn/problem.php?pid=2150

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

题意分析:

两个人在玩游戏,在一块草地上,有的地方是木板,木板不可被烧,两个人各选取一个地方开始烧火, 每一秒钟火会向四周蔓延,求如果两个人的起始烧火位置都是最佳的,最少多少秒可以烧光所有草地。

解题思路:

思路1:遍历所有的点,如果两点都是草地,那么对两点进行BFS,更新最短时间。

思路2:先把草地的点存下来,再遍历两点BFS。略快于思路1。

 

思路1代码:

#include <stdio.h>
#include <string.h>
#include <queue> 
#include <algorithm>
#define N 12
using namespace std;
char str[N][N];
bool book[N][N];
int n, m, ans;
struct edge{
	int x;
	int y;
	int temp;
	edge(int x, int y, int temp) : x(x), y(y), temp(temp) {}
};
int bfs(int s1, int s2, int s3, int s4)
{
	memset(book, false, sizeof(book));
	int nex[4][2]={0,1, 0,-1, 1,0, -1,0};
	book[s1][s2]=book[s3][s4]=true;
	queue<edge>q;
	q.push(edge(s1, s2, 0));
	q.push(edge(s3, s4, 0));
	int sum=0;
	while(!q.empty())
	{
		edge u=q.front();
		q.pop();
		sum=max(sum, u.temp);
		if(sum>ans)
			return -1;
		for(int i=0; i<4; i++)
		{
			int tx=u.x+nex[i][0];
			int ty=u.y+nex[i][1];
			if(tx>=n || ty>=m || tx<0 || ty<0 || book[tx][ty]==true)
				continue;
			if(str[tx][ty]=='#')
			{
				q.push(edge(tx, ty, u.temp+1));
				book[tx][ty]=true;
			}
		}
	}
	for(int i=0; i<n; i++)
		for(int j=0; j<m; j++)	
			if(book[i][j]==false && str[i][j]=='#')
				return -1;
	return sum;
}
int main()
{
	int t=0, T;
	scanf("%d", &T);
	while(T--)
	{
		ans=0x3f3f3f3f;
		scanf("%d%d", &n, &m);
		for(int i=0; i<n; i++)
			scanf("%s", str[i]);
		for(int i=0; i<n; i++)
			for(int j=0; j<m; j++)
				for(int p=0; p<n; p++)
					for(int q=0; q<m; q++)
					{
						if(str[i][j]=='#' && str[p][q]=='#')
						{
							int s=bfs(i, j, p, q);
							if(s!=-1 && s<ans)
							{
								ans=s;
								//printf("%d %d %d %d\n", i, j, p, q);
							}
								
						}
					
					}
		if(ans!=0x3f3f3f3f)
			printf("Case %d: %d\n", ++t, ans);
		else
			printf("Case %d: -1\n", ++t);		
	}
	return 0;
} 

思路2代码:

#include <stdio.h>
#include <string.h>
#include <queue> 
#include <algorithm>
#define N 20
using namespace std;
char str[N][N];
bool book[N][N];
int n, m, ans;
struct edge{
	int x;
	int y;
	int temp;
	edge(){}
	edge(int x, int y, int temp) : x(x), y(y), temp(temp) {}
}a[N*N];
int bfs(int s1, int s2, int s3, int s4)
{
	memset(book, false, sizeof(book));
	int nex[4][2]={0,1, 0,-1, 1,0, -1,0};
	book[s1][s2]=book[s3][s4]=true;
	queue<edge>q;
	q.push(edge(s1, s2, 0));
	q.push(edge(s3, s4, 0));
	int sum=0;
	while(!q.empty())
	{
		edge u=q.front();
		q.pop();
		sum=max(sum, u.temp);
		if(sum>ans)
			return -1;
		for(int i=0; i<4; i++)
		{
			int tx=u.x+nex[i][0];
			int ty=u.y+nex[i][1];
			if(tx>=n || ty>=m || tx<0 || ty<0 || book[tx][ty]==true)
				continue;
			if(str[tx][ty]=='#')
			{
				q.push(edge(tx, ty, u.temp+1));
				book[tx][ty]=true;
			}
		}
	}
	for(int i=0; i<n; i++)
		for(int j=0; j<m; j++)	
			if(book[i][j]==false && str[i][j]=='#')
				return -1;
	return sum;
}
int main()
{
	int t=0, T;
	scanf("%d", &T);
	while(T--)
	{
		ans=0x3f3f3f3f;
		scanf("%d%d", &n, &m);
		for(int i=0; i<n; i++)
			scanf("%s", str[i]);
		int len=0;
		for(int i=0; i<n; i++)
			for(int j=0; j<m; j++)
				if(str[i][j]=='#')
					{
						a[len].x=i;
						a[len].y=j;
						len++;
					}
		for(int i=0; i<len; i++)
			for(int j=i; j<len; j++)
			{
				int s=bfs(a[i].x, a[i].y, a[j].x, a[j].y);
				if(s!=-1 && s<ans)
				{
					ans=s;
				}
			}
		if(ans!=0x3f3f3f3f)
			printf("Case %d: %d\n", ++t, ans);
		else
			printf("Case %d: -1\n", ++t);		
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

张宜强

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值